summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-18 03:30:57 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-18 03:30:57 +0000
commit56b1509a231910e9fa379c0a6a9488823a544448 (patch)
treed6bab09c12ff1b7f2430470d2a23b09c9087ecb1 /games-simulation/dangerdeep
parentStable for HPPA (bug #271889). (diff)
downloadgentoo-2-56b1509a231910e9fa379c0a6a9488823a544448.tar.gz
gentoo-2-56b1509a231910e9fa379c0a6a9488823a544448.tar.bz2
gentoo-2-56b1509a231910e9fa379c0a6a9488823a544448.zip
Fix building with gcc-4.4, bug #273524
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-simulation/dangerdeep')
-rw-r--r--games-simulation/dangerdeep/ChangeLog6
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild5
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch20
3 files changed, 28 insertions, 3 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index 23e7823f5f13..0fd99486d263 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.9 2009/01/20 06:00:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.10 2009/06/18 03:30:57 nyhm Exp $
+
+ 18 Jun 2009; Tristan Heaven <nyhm@gentoo.org> dangerdeep-0.3.0.ebuild,
+ +files/dangerdeep-0.3.0-gcc44.patch:
+ Fix building with gcc-4.4, bug #273524
20 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
dangerdeep-0.3.0.ebuild:
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
index 51e765b74e37..d675b2298bd9 100644
--- a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.5 2009/01/20 06:00:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.6 2009/06/18 03:30:57 nyhm Exp $
EAPI=2
inherit eutils games
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
sed -i \
-e "/console_log.txt/ s:fopen.*:stderr;:" \
src/system.cpp \
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch
new file mode 100644
index 000000000000..23d3c470c900
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc44.patch
@@ -0,0 +1,20 @@
+--- src/date.cpp
++++ src/date.cpp
+@@ -22,6 +22,7 @@
+
+ #include <iomanip>
+ #include <cstdlib>
++#include <cstdio>
+ #include "date.h"
+ #include "texts.h"
+
+--- src/filehelper.cpp
++++ src/filehelper.cpp
+@@ -23,6 +23,7 @@
+ #include "filehelper.h"
+ #include "error.h"
+ #include <vector>
++#include <cstdio>
+ using namespace std;
+
+ #ifdef WIN32