summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-12 22:47:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-12 22:47:26 +0000
commitc580809f2cde1229525d555d0608b05b39b601f0 (patch)
tree9aba76093e0939fe1fe21799d9137dc1d9b1f4e6 /games-rpg
parentStable on alpha, bug #253668 (diff)
downloadgentoo-2-c580809f2cde1229525d555d0608b05b39b601f0.tar.gz
gentoo-2-c580809f2cde1229525d555d0608b05b39b601f0.tar.bz2
gentoo-2-c580809f2cde1229525d555d0608b05b39b601f0.zip
EAPI=2; fix improper die usage (bug #258770)
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/coe2/ChangeLog7
-rw-r--r--games-rpg/coe2/coe2-2007.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/games-rpg/coe2/ChangeLog b/games-rpg/coe2/ChangeLog
index f31c91e43593..95f528ef353a 100644
--- a/games-rpg/coe2/ChangeLog
+++ b/games-rpg/coe2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/coe2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/ChangeLog,v 1.1 2007/08/29 21:38:39 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/ChangeLog,v 1.2 2009/02/12 22:47:26 mr_bones_ Exp $
+
+ 12 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> coe2-2007.ebuild:
+ EAPI=2; fix improper die usage (bug #258770)
*coe2-2007 (29 Aug 2007)
diff --git a/games-rpg/coe2/coe2-2007.ebuild b/games-rpg/coe2/coe2-2007.ebuild
index 7ca1bfc0aa5e..720a93d3ebf8 100644
--- a/games-rpg/coe2/coe2-2007.ebuild
+++ b/games-rpg/coe2/coe2-2007.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/coe2-2007.ebuild,v 1.1 2007/08/29 21:38:39 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/coe2-2007.ebuild,v 1.2 2009/02/12 22:47:26 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Precursor to the Dominions series"
@@ -19,13 +20,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/coe
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
rm *.{dll,exe}
rm -r old
- use amd64 && mv -f coe_linux64bit coe_linux || die "mv amd64 image failed"
+ if use amd64 ; then
+ mv -f coe_linux64bit coe_linux || die "mv amd64 image failed"
+ fi
}
src_install() {