summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-12 15:24:03 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-12 15:24:03 +0000
commit6370ab170e418ce4be3c8b7d4279f5686f5bd0c9 (patch)
tree14a01875b6cc239dbb083a4436716719ac92eac0 /games-rpg
parentStable for HPPA (bug #509992). (diff)
downloadgentoo-2-6370ab170e418ce4be3c8b7d4279f5686f5bd0c9.tar.gz
gentoo-2-6370ab170e418ce4be3c8b7d4279f5686f5bd0c9.tar.bz2
gentoo-2-6370ab170e418ce4be3c8b7d4279f5686f5bd0c9.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/sumwars/ChangeLog9
-rw-r--r--games-rpg/sumwars/sumwars-0.5.8.ebuild100
2 files changed, 107 insertions, 2 deletions
diff --git a/games-rpg/sumwars/ChangeLog b/games-rpg/sumwars/ChangeLog
index c1db5c5c4844..eaed3991347e 100644
--- a/games-rpg/sumwars/ChangeLog
+++ b/games-rpg/sumwars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/sumwars
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/sumwars/ChangeLog,v 1.12 2013/08/17 20:30:45 calchan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sumwars/ChangeLog,v 1.13 2014/05/12 15:24:03 hasufell Exp $
+
+*sumwars-0.5.8 (12 May 2014)
+
+ 12 May 2014; Julian Ospald <hasufell@gentoo.org> +sumwars-0.5.8.ebuild:
+ version bump
17 Aug 2013; Denis Dupeyron <calchan@gentoo.org> sumwars-0.5.6-r2.ebuild:
Improve cegui dependency for better resolution.
diff --git a/games-rpg/sumwars/sumwars-0.5.8.ebuild b/games-rpg/sumwars/sumwars-0.5.8.ebuild
new file mode 100644
index 000000000000..2083ae930d6c
--- /dev/null
+++ b/games-rpg/sumwars/sumwars-0.5.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sumwars/sumwars-0.5.8.ebuild,v 1.1 2014/05/12 15:24:03 hasufell Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils flag-o-matic gnome2-utils games
+
+DESCRIPTION="a multi-player, 3D action role-playing game"
+HOMEPAGE="http://sumwars.org"
+SRC_URI="mirror://sourceforge/sumwars/${P//_/-}-src.tar.bz2"
+
+LICENSE="GPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools debug"
+
+LANGS="de en it pl pt ru uk"
+for L in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${L}"
+done
+unset L
+
+RDEPEND="
+ >=dev-games/cegui-0.8[ogre]
+ >=dev-games/ogre-1.7.4-r1[freeimage,opengl]
+ dev-games/ois
+ dev-games/physfs
+ >=dev-lang/lua-5.1
+ >=dev-libs/tinyxml-2.6.2-r2
+ media-libs/freealut
+ media-libs/openal
+ media-libs/libogg
+ media-libs/libvorbis
+ >=net-libs/enet-1.3.0
+ x11-libs/libX11
+ x11-libs/libXrandr
+ tools? ( dev-libs/boost )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV%_*}
+
+src_configure() {
+ # QA
+ append-flags -fno-strict-aliasing
+
+ use debug && CMAKE_BUILD_TYPE=Debug
+
+ local l langs
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ langs="${langs} ${l}"
+ fi
+ done
+
+ [[ -z "${langs}" ]] && langs="en"
+
+ # configure sumwars with cmake
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=""
+ -DSUMWARS_LANGUAGES="${langs}"
+ -DSUMWARS_NO_TINYXML=ON
+ -DSUMWARS_NO_ENET=ON
+ -DSUMWARS_DOC_DIR="/usr/share/doc/${PF}"
+ -DSUMWARS_EXECUTABLE_DIR="${GAMES_BINDIR}"
+ -DSUMWARS_SHARE_DIR="${GAMES_DATADIR}/${PN}"
+ -DSUMWARS_STANDALONE_MODE=OFF
+ -DSUMWARS_POST_BUILD_COPY=OFF
+ -DSUMWARS_PORTABLE_MODE=OFF
+ -DSUMWARS_RANDOM_REGIONS=ON
+ $(cmake-utils_use tools SUMWARS_BUILD_TOOLS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon -s 128 share/icon/SumWarsIcon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Summoning Wars"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}