summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-11 22:00:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-11 22:00:58 +0000
commit458f3c72ffd4bb0658452ae299dc9a8417e19646 (patch)
tree03e2ad0b767d6bf99eab7a66ad5539322cd40b12 /games-rpg
parentMoved dev-lisp/guile-pg to dev-scheme/guile-pg (diff)
downloadgentoo-2-458f3c72ffd4bb0658452ae299dc9a8417e19646.tar.gz
gentoo-2-458f3c72ffd4bb0658452ae299dc9a8417e19646.tar.bz2
gentoo-2-458f3c72ffd4bb0658452ae299dc9a8417e19646.zip
Added a new revision to work with the split openal/freealut. Closing bug #110709.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/eternal-lands/ChangeLog9
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r2.ebuild103
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r26
3 files changed, 117 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 5c6c8b3e225a..f498d6c66c87 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.15 2006/04/28 02:59:31 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.16 2006/05/11 22:00:58 wolf31o2 Exp $
+
+*eternal-lands-1.2.0_p1-r2 (11 May 2006)
+
+ 11 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +eternal-lands-1.2.0_p1-r2.ebuild:
+ Added a new revision to work with the split openal/freealut. Closing bug
+ #110709.
28 Apr 2006; Alec Warner <antarus@gentoo.org> Manifest:
Fixing SHA256 digest, pass five
diff --git a/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r2.ebuild b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r2.ebuild
new file mode 100644
index 000000000000..e35d4f661c9b
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r2.ebuild,v 1.1 2006/05/11 22:00:58 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tgz
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext )
+ virtual/x11 )
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ =media-libs/cal3d-0.10.0
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-apps/findutils
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="konqueror"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Allow compiled vertex arrays to be togglable as they don't seem to work
+ # with xorg drivers on IGP style cards.
+ epatch "${FILESDIR}/${PN}-1.2.0-vertex-array.patch"
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ -e 's/ -DAUTO_UPDATE//' \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt *.lst \
+ actor_defs books languages \
+ || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r2 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r2
new file mode 100644
index 000000000000..ec8e42ae0a6d
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r2
@@ -0,0 +1,6 @@
+MD5 15492252c997253a90e6eec4f9edfeae elc_120p1.tgz 731594
+RMD160 a06be332015a8db57c3455f9918e3b58cfe92a41 elc_120p1.tgz 731594
+SHA256 a610102e92e91c6c69c4ceef906ae5010280267a1b9f55ec71f172e3691f0674 elc_120p1.tgz 731594
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955