summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-20 23:53:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-20 23:53:29 +0000
commitfc21223057e8b46aaa44b84769c81ee4390522b6 (patch)
treeda953aa5fd51c987d7e53c942d8adfa87cbca350 /games-rpg/planeshift
parentsrc_compile() -> src_unpack(), bug #75054 (Manifest recommit) (diff)
downloadgentoo-2-fc21223057e8b46aaa44b84769c81ee4390522b6.tar.gz
gentoo-2-fc21223057e8b46aaa44b84769c81ee4390522b6.tar.bz2
gentoo-2-fc21223057e8b46aaa44b84769c81ee4390522b6.zip
fix curl include - bug #75104
Diffstat (limited to 'games-rpg/planeshift')
-rw-r--r--games-rpg/planeshift/ChangeLog6
-rw-r--r--games-rpg/planeshift/planeshift-0.2.010-r1.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/games-rpg/planeshift/ChangeLog b/games-rpg/planeshift/ChangeLog
index 59f0325ff896..2f5ef9915274 100644
--- a/games-rpg/planeshift/ChangeLog
+++ b/games-rpg/planeshift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/planeshift
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/ChangeLog,v 1.5 2004/06/24 23:16:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/ChangeLog,v 1.6 2004/12/20 23:53:29 mr_bones_ Exp $
+
+ 20 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ planeshift-0.2.010-r1.ebuild:
+ fix curl include - bug #75104
21 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
planeshift-0.2.010-r1.ebuild:
diff --git a/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild b/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
index cf890c77c911..09d9babf510b 100644
--- a/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
+++ b/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild,v 1.10 2004/11/05 20:06:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild,v 1.11 2004/12/20 23:53:29 mr_bones_ Exp $
inherit eutils games
@@ -28,7 +28,12 @@ export CEL_PREFIX=${CEL_PREFIX:-${CRYSTAL_PREFIX}}
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${P}-fix-cast.diff"
+ sed -i \
+ -e 's:curl/types.h:curl/curl.h:' \
+ src/updater/httpclient/download.h \
+ || die "sed failed"
}
src_compile() {