summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-12 21:40:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-12 21:40:55 +0000
commitc9852bccd5f0276d32f6b9baa0e99d13e6869660 (patch)
tree3ab9109393121137d2f355cbb00dada13f93ef1a /games-rpg/freedroidrpg
parentVersion bump. (diff)
downloadgentoo-2-c9852bccd5f0276d32f6b9baa0e99d13e6869660.tar.gz
gentoo-2-c9852bccd5f0276d32f6b9baa0e99d13e6869660.tar.bz2
gentoo-2-c9852bccd5f0276d32f6b9baa0e99d13e6869660.zip
avoid compile breakage with newer sdl-gfx (bug #324483)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-rpg/freedroidrpg')
-rw-r--r--games-rpg/freedroidrpg/ChangeLog7
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.13-sdl-gfx.patch21
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch21
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild5
4 files changed, 30 insertions, 24 deletions
diff --git a/games-rpg/freedroidrpg/ChangeLog b/games-rpg/freedroidrpg/ChangeLog
index 3ad5410a714d..489c4c3c0519 100644
--- a/games-rpg/freedroidrpg/ChangeLog
+++ b/games-rpg/freedroidrpg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/freedroidrpg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.26 2010/04/19 07:19:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.27 2010/07/12 21:40:55 mr_bones_ Exp $
+
+ 12 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ freedroidrpg-0.13.ebuild, +files/freedroidrpg-0.13-sdl-gfx.patch,
+ files/freedroidrpg-0.13-syslibs.patch:
+ avoid compile breakage with newer sdl-gfx (bug #324483)
19 Apr 2010; Tupone Alfredo <tupone@gentoo.org> freedroidrpg-0.13.ebuild:
Force python2 version. Fix bug #312275 by arfrever@gentoo.org
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.13-sdl-gfx.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-sdl-gfx.patch
new file mode 100644
index 000000000000..20031dbb7d70
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-sdl-gfx.patch
@@ -0,0 +1,21 @@
+diff -ru freedroidrpg-0.13.orig/src/struct.h freedroidrpg-0.13/src/struct.h
+--- freedroidrpg-0.13.orig/src/struct.h 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/struct.h 2010-01-25 11:35:34.764604580 -0500
+@@ -30,16 +30,7 @@
+ #include "system.h"
+ #include "defs.h"
+
+-typedef struct tColorRGBA {
+- Uint8 r;
+- Uint8 g;
+- Uint8 b;
+- Uint8 a;
+-} tColorRGBA, myColor;
+-
+-typedef struct tColorY {
+- Uint8 y;
+-} tColorY;
++typedef tColorRGBA myColor;
+
+ /**
+ * Simple doubly linked list implementation.
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
index 0e0209d78d6e..3064d0a68e5a 100644
--- a/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
@@ -68,27 +68,6 @@ diff -ru freedroidrpg-0.13.orig/src/lua.c freedroidrpg-0.13/src/lua.c
/* Our Lua state for event execution */
lua_State *global_lua_state;
-diff -ru freedroidrpg-0.13.orig/src/struct.h freedroidrpg-0.13/src/struct.h
---- freedroidrpg-0.13.orig/src/struct.h 2010-01-21 07:31:29.000000000 -0500
-+++ freedroidrpg-0.13/src/struct.h 2010-01-25 11:35:34.764604580 -0500
-@@ -30,16 +30,7 @@
- #include "system.h"
- #include "defs.h"
-
--typedef struct tColorRGBA {
-- Uint8 r;
-- Uint8 g;
-- Uint8 b;
-- Uint8 a;
--} tColorRGBA, myColor;
--
--typedef struct tColorY {
-- Uint8 y;
--} tColorY;
-+typedef tColorRGBA myColor;
-
- /**
- * Simple doubly linked list implementation.
diff -ru freedroidrpg-0.13.orig/src/system.h freedroidrpg-0.13/src/system.h
--- freedroidrpg-0.13.orig/src/system.h 2010-01-21 07:31:29.000000000 -0500
+++ freedroidrpg-0.13/src/system.h 2010-01-25 11:35:53.944486530 -0500
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild
index 2a909cbfdc29..a424dc9dfca2 100644
--- a/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild,v 1.4 2010/04/19 07:19:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild,v 1.5 2010/07/12 21:40:55 mr_bones_ Exp $
EAPI=2
PYTHON_DEPEND="2"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE="opengl"
-RDEPEND="media-libs/libsdl[video]
+RDEPEND="media-libs/libsdl[opengl?,video]
dev-lang/lua
media-libs/jpeg
media-libs/libpng
@@ -39,6 +39,7 @@ pkg_setup() {
src_prepare() {
rm -rf lua src/SDL_rotozoom*
epatch "${FILESDIR}"/${P}-syslibs.patch
+ has_version '<media-libs/sdl-gfx-2.0.21' && epatch "${FILESDIR}"/${P}-sdl-gfx.patch
python_convert_shebangs -r 2 .