summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-17 04:00:40 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-17 04:00:40 +0000
commit726b0a13ba29ce61ad5330aaa2a187120b9fb510 (patch)
treea7107f6c3199b4b65eee2948449d454dbad89b8e /games-puzzle
parentversion bump wrt #452280 (diff)
downloadgentoo-2-726b0a13ba29ce61ad5330aaa2a187120b9fb510.tar.gz
gentoo-2-726b0a13ba29ce61ad5330aaa2a187120b9fb510.tar.bz2
gentoo-2-726b0a13ba29ce61ad5330aaa2a187120b9fb510.zip
version bump
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xblockout/ChangeLog10
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-font.patch46
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6.ebuild54
3 files changed, 108 insertions, 2 deletions
diff --git a/games-puzzle/xblockout/ChangeLog b/games-puzzle/xblockout/ChangeLog
index 5b48a535b47f..2a5f790b621b 100644
--- a/games-puzzle/xblockout/ChangeLog
+++ b/games-puzzle/xblockout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/xblockout
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.25 2010/10/15 12:23:02 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.26 2013/02/17 04:00:40 hasufell Exp $
+
+*xblockout-1.1.6 (17 Feb 2013)
+
+ 17 Feb 2013; Julian Ospald <hasufell@gentoo.org> +xblockout-1.1.6.ebuild,
+ +files/xblockout-1.1.6-font.patch:
+ version bump
15 Oct 2010; Tupone Alfredo <tupone@gentoo.org> xblockout-1.1.5-r1.ebuild:
Respect LDFLAGS. Bug #335051 by flameeyes@gentoo.org
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
new file mode 100644
index 000000000000..bb0302963bdc
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
@@ -0,0 +1,46 @@
+--- initmenu.c.old 2008-10-27 23:23:43.000000000 +0100
++++ initmenu.c 2008-10-27 23:22:52.000000000 +0100
+@@ -408,19 +408,17 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+ "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ m->font = m->xfont->fid;
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
+ fprintf(stderr,"Have you A font?\n");
+@@ -428,17 +426,17 @@
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;
diff --git a/games-puzzle/xblockout/xblockout-1.1.6.ebuild b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
new file mode 100644
index 000000000000..1df69c34f27d
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.6.ebuild,v 1.1 2013/02/17 04:00:40 hasufell Exp $
+
+EAPI=5
+inherit flag-o-matic eutils games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="http://www710.univ-lyon1.fr/~exco/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die "sed failed"
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+}
+
+src_compile() {
+ emake \
+ USE_SETGID= \
+ SCOREDIR="${GAMES_DATADIR}/${PN}" \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newgamesbin bl xbl
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+ make_desktop_entry xbl XBlockOut
+ prepgamesdirs
+}