summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-02 16:57:40 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-02 16:57:40 +0000
commit5dc1ad381f248dc283807f7865147df78f510b2b (patch)
treec7f7d657dfeab95c2236c42d0d6d3b5a9f27f0d9 /games-puzzle
parentNew package - DownloadManager for rox desktop. Imported from breakmygentoo.ne... (diff)
downloadgentoo-2-5dc1ad381f248dc283807f7865147df78f510b2b.tar.gz
gentoo-2-5dc1ad381f248dc283807f7865147df78f510b2b.tar.bz2
gentoo-2-5dc1ad381f248dc283807f7865147df78f510b2b.zip
Version bump
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xblockout/ChangeLog7
-rw-r--r--games-puzzle/xblockout/files/digest-xblockout-1.1.32
-rw-r--r--games-puzzle/xblockout/files/digest-xblockout-1.1.43
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.4.ebuild54
4 files changed, 65 insertions, 1 deletions
diff --git a/games-puzzle/xblockout/ChangeLog b/games-puzzle/xblockout/ChangeLog
index bf86cac2b759..b02dae5fb81c 100644
--- a/games-puzzle/xblockout/ChangeLog
+++ b/games-puzzle/xblockout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/xblockout
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.11 2006/02/14 04:20:47 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.12 2006/10/02 16:57:40 nyhm Exp $
+
+*xblockout-1.1.4 (02 Oct 2006)
+
+ 02 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +xblockout-1.1.4.ebuild:
+ Version bump
14 Feb 2006; Joshua Baergen <joshuabaergen@gentoo.org>
xblockout-1.1.3.ebuild:
diff --git a/games-puzzle/xblockout/files/digest-xblockout-1.1.3 b/games-puzzle/xblockout/files/digest-xblockout-1.1.3
index 9b423346d639..7b477e8399e3 100644
--- a/games-puzzle/xblockout/files/digest-xblockout-1.1.3
+++ b/games-puzzle/xblockout/files/digest-xblockout-1.1.3
@@ -1 +1,3 @@
MD5 2fcada6f23e1f4bb3c4a33481bfefb80 xbl-1.1.3.tar.gz 136411
+RMD160 9356b3912982709434cc105122c1c02814e40558 xbl-1.1.3.tar.gz 136411
+SHA256 c6752a59ceef9f28b2df36df7da5c8018edc1be4cb977ca74558865620284e85 xbl-1.1.3.tar.gz 136411
diff --git a/games-puzzle/xblockout/files/digest-xblockout-1.1.4 b/games-puzzle/xblockout/files/digest-xblockout-1.1.4
new file mode 100644
index 000000000000..28b45b0fefc6
--- /dev/null
+++ b/games-puzzle/xblockout/files/digest-xblockout-1.1.4
@@ -0,0 +1,3 @@
+MD5 767ea5b713221452c026fac89b1415f4 xbl-1.1.4.tar.gz 136445
+RMD160 ad0ea087187c4d5895a0f91d7e8313773777aea9 xbl-1.1.4.tar.gz 136445
+SHA256 b51a371f0808fbfad7487b9f396eea394ad85b01e89ee51179db041fa33b3fab xbl-1.1.4.tar.gz 136445
diff --git a/games-puzzle/xblockout/xblockout-1.1.4.ebuild b/games-puzzle/xblockout/xblockout-1.1.4.ebuild
new file mode 100644
index 000000000000..c276d2a1b483
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.4.ebuild,v 1.1 2006/10/02 16:57:40 nyhm Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="http://www710.univ-lyon1.fr/~exco/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXext"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+
+ egamesconf || die
+ emake \
+ USE_SETGID= \
+ SCOREDIR="${GAMES_DATADIR}/${PN}" \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ newgamesbin bl xbl || die "newgamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl || die "doins failed"
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+
+ prepgamesdirs
+}