summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-06-24 20:45:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-06-24 20:45:12 +0000
commit2c540a44db2b66ca2c9529b80202a187982fe48d (patch)
treec84fc0e54a46697c534d97cd55a5e8dc0c4e2f8d /games-puzzle
parentinstalling the config files (diff)
downloadgentoo-2-2c540a44db2b66ca2c9529b80202a187982fe48d.tar.gz
gentoo-2-2c540a44db2b66ca2c9529b80202a187982fe48d.tar.bz2
gentoo-2-2c540a44db2b66ca2c9529b80202a187982fe48d.zip
Fix overflow. Bug #458458
(Portage version: 2.1.12.8/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/icebreaker/ChangeLog6
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch20
-rw-r--r--games-puzzle/icebreaker/icebreaker-1.9.6.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/games-puzzle/icebreaker/ChangeLog b/games-puzzle/icebreaker/ChangeLog
index ab548d5638be..88e4596e78f3 100644
--- a/games-puzzle/icebreaker/ChangeLog
+++ b/games-puzzle/icebreaker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/icebreaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.17 2013/02/17 22:04:38 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.18 2013/06/24 20:45:12 tupone Exp $
+
+ 24 Jun 2013; Tupone Alfredo <tupone@gentoo.org> icebreaker-1.9.6.ebuild,
+ +files/icebreaker-1.9.6-ovfl.patch:
+ Fix overflow. Bug #458458 by Diego
*icebreaker-1.9.6 (17 Feb 2013)
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch
new file mode 100644
index 000000000000..5a59b04f79af
--- /dev/null
+++ b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch
@@ -0,0 +1,20 @@
+--- menu.c.old 2013-06-24 22:09:11.606750080 +0200
++++ menu.c 2013-06-24 22:25:51.635735351 +0200
+@@ -522,7 +522,7 @@
+ { // "random", at the end/beginning of the list
+
+ strcpy(options.theme,"random");
+- snprintf(options.theme,MAXMENUVALUELENGTH,"random");
++ snprintf(options.theme,MAXTHEMENAMELENGTH,"random");
+
+ settheme("linux"); // just for pretty
+
+@@ -544,7 +544,7 @@
+ {
+ if (t<0) t=themecount;
+ strncpy(val,themelist[(t-1)%themecount],MAXMENUVALUELENGTH);
+- snprintf(options.theme,MAXMENUVALUELENGTH,themelist[(t-1)%themecount]);
++ snprintf(options.theme,MAXTHEMENAMELENGTH,themelist[(t-1)%themecount]);
+ }
+
+ settheme(options.theme);
diff --git a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
index 025f286c43a3..246169fcc72f 100644
--- a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
+++ b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.1 2013/02/17 22:04:38 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.2 2013/06/24 20:45:12 tupone Exp $
EAPI=5
inherit eutils games
@@ -20,7 +20,8 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-ldflags.patch
"${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-parallell-install.patch )
+ "${FILESDIR}"/${P}-parallell-install.patch
+ "${FILESDIR}"/${P}-ovfl.patch )
src_compile() {
emake \