summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-14 00:12:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-14 00:12:44 +0000
commit0e079bc6049681e927b820fabe75cac698d89d56 (patch)
tree29de32f4eb18d362586bef0e485275bb9a2fecad /games-puzzle/triptych-demo
parentFix #73972. (Manifest recommit) (diff)
downloadgentoo-2-0e079bc6049681e927b820fabe75cac698d89d56.tar.gz
gentoo-2-0e079bc6049681e927b820fabe75cac698d89d56.tar.bz2
gentoo-2-0e079bc6049681e927b820fabe75cac698d89d56.zip
Fix permissions #74217 by Alexandru Toma.
Diffstat (limited to 'games-puzzle/triptych-demo')
-rw-r--r--games-puzzle/triptych-demo/ChangeLog5
-rw-r--r--games-puzzle/triptych-demo/triptych-demo-0.ebuild15
2 files changed, 18 insertions, 2 deletions
diff --git a/games-puzzle/triptych-demo/ChangeLog b/games-puzzle/triptych-demo/ChangeLog
index 3fcd7ff5b4a5..d7b9d334603c 100644
--- a/games-puzzle/triptych-demo/ChangeLog
+++ b/games-puzzle/triptych-demo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/triptych-demo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/ChangeLog,v 1.1 2004/12/08 04:33:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/ChangeLog,v 1.2 2004/12/14 00:12:44 vapier Exp $
+
+ 13 Dec 2004; Mike Frysinger <vapier@gentoo.org> triptych-demo-0.ebuild:
+ Fix permissions #74217 by Alexandru Toma.
*triptych-demo-0 (07 Dec 2004)
diff --git a/games-puzzle/triptych-demo/triptych-demo-0.ebuild b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
index 0e7704c68143..d249cffdc72c 100644
--- a/games-puzzle/triptych-demo/triptych-demo-0.ebuild
+++ b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/triptych-demo-0.ebuild,v 1.1 2004/12/08 04:33:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/triptych-demo-0.ebuild,v 1.2 2004/12/14 00:12:44 vapier Exp $
inherit games eutils
@@ -29,3 +29,16 @@ src_install() {
prepgamesdirs
}
+
+pkg_postinst() {
+ # Fix perms on status files #74217
+ local f
+ for f in triptych.{clr,cnt,scr} ; do
+ f="${ROOT}/${GAMES_PREFIX_OPT}/${PN}/${f}"
+ if [[ ! -e ${f} ]] ; then
+ touch "${f}"
+ chmod 660 "${f}"
+ chown ${GAMES_USER}:${GAMES_GROUP} "${f}"
+ fi
+ done
+}