summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-04 19:09:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-04 19:09:49 +0000
commit0d335e792dce1eae478d01a59c0f0ffd0b735414 (patch)
tree394225556a44d1c3d03487aaad8d801faf077661 /games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
parentStable on Alpha as per security bug #172293 (diff)
downloadgentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.tar.gz
gentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.tar.bz2
gentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.zip
Fix for tclx-8.4
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild')
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
new file mode 100644
index 000000000000..cf8e71067077
--- /dev/null
+++ b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild,v 1.1 2007/04/04 19:09:49 nyhm Exp $
+
+inherit games
+
+DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
+HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
+SRC_URI="http://www.naskita.com/linux/${PN}/${PN}.zip"
+
+LICENSE="penguzzle"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/tk
+ dev-tcltk/tclx"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:~/puzz/images:${GAMES_DATADIR}/${PN}:" \
+ lib/init \
+ || die "sed init failed"
+ sed -i \
+ -e "s:~/puzz/lib:$(games_get_libdir)/${PN}:" \
+ bin/${PN} \
+ || die "sed ${PN} failed"
+
+ epatch "${FILESDIR}"/${P}-tclx.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins images/img0.gif || die "doins img0.gif failed"
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib/init || die "doins init failed"
+
+ dogamesbin bin/${PN} || die "dogamesbin failed"
+
+ dodoc README
+ prepgamesdirs
+}