summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit2f7b073c1bc54c873666c4522cd6cd49ac1d59df (patch)
tree072f3e7b49f6b078b595b1483277009b1f03d0f6 /games-puzzle/pathological
parentgames-puzzle (diff)
downloadgentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.gz
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.bz2
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/pathological')
-rw-r--r--games-puzzle/pathological/ChangeLog19
-rw-r--r--games-puzzle/pathological/Manifest3
-rw-r--r--games-puzzle/pathological/files/digest-pathological-1.1.21
-rw-r--r--games-puzzle/pathological/pathological-1.1.2.ebuild69
4 files changed, 92 insertions, 0 deletions
diff --git a/games-puzzle/pathological/ChangeLog b/games-puzzle/pathological/ChangeLog
new file mode 100644
index 000000000000..5ee5272efb77
--- /dev/null
+++ b/games-puzzle/pathological/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for app-games/pathological
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pathological/ChangeLog,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+ 10 Jul 2003; Michael Sterrett <msterret@gentoo.org>
+ pathological-1.1.2.ebuild:
+ fix DESCRIPTION
+
+ 10 Jul 2003; Michael Sterrett <msterret@gentoo.org>
+ pathological-1.1.2.ebuild:
+ Don't use doexe for pathological.py to avoid trying to strip it.
+ Use insopts for getting file perms right.
+
+*pathological-1.1.2 (10 Jul 2003)
+
+ 10 Jul 2003; Michael Sterrett <msterret@gentoo.org>
+ pathological-1.1.2.ebuild:
+ Initial commit. ebuild not based on user submitted ebuild. (bug 23443)
+
diff --git a/games-puzzle/pathological/Manifest b/games-puzzle/pathological/Manifest
new file mode 100644
index 000000000000..afd6c1cd47bb
--- /dev/null
+++ b/games-puzzle/pathological/Manifest
@@ -0,0 +1,3 @@
+MD5 30a63adf6049a317a3cf0975e47a428c pathological-1.1.2.ebuild 1652
+MD5 81572bab8bcf0e337b95c1226805552f ChangeLog 718
+MD5 23b647c8cc1fa2737510a5972b26aa89 files/digest-pathological-1.1.2 71
diff --git a/games-puzzle/pathological/files/digest-pathological-1.1.2 b/games-puzzle/pathological/files/digest-pathological-1.1.2
new file mode 100644
index 000000000000..b9920ee4bf0c
--- /dev/null
+++ b/games-puzzle/pathological/files/digest-pathological-1.1.2
@@ -0,0 +1 @@
+MD5 40091e7c3a391a52f6b6806770ab944f pathological_1.1.2.tar.gz 7000094
diff --git a/games-puzzle/pathological/pathological-1.1.2.ebuild b/games-puzzle/pathological/pathological-1.1.2.ebuild
new file mode 100644
index 000000000000..59a11743bf4a
--- /dev/null
+++ b/games-puzzle/pathological/pathological-1.1.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pathological/pathological-1.1.2.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+MY_P="${P/-/_}"
+DESCRIPTION="An enriched clone of the game 'Logical' by Rainbow Arts"
+HOMEPAGE="http://pathological.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pathological/${MY_P}.tar.gz"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( media-libs/netpbm )
+ >=sys-apps/sed-4"
+RDEPEND=">=dev-python/pygame-1.5.5
+ dev-lang/python"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use doc && {
+ sed -i \
+ -e '5,$ s/=/ /g' makehtml || \
+ die "sed makehtml failed"
+ } || {
+ echo "#!/bin/sh" > makehtml || \
+ die "clearing makehtml failed"
+ }
+
+ sed -i \
+ -e "/^cd / s/usr/share/pathological${GAMES_DATADIR}/${PN}" \
+ pathological || die "sed pathological failed"
+
+ sed -i \
+ -e "/^write_highscores / s/usr/lib/pathological/bin${GAMES_LIBDIR}/${PN}" \
+ pathological.py || die "sed pathological.py failed"
+}
+
+src_install() {
+ # executables
+ dogamesbin pathological
+ insinto ${GAMES_DATADIR}/${PN}
+ insopts -m0750
+ doins pathological.py
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe write-highscores
+
+ # removed some unneeded resource files
+ rm -f graphics/*.xcf
+ rm -f sounds/*.orig
+ # "install" resource files
+ mv circuits graphics music sounds ${D}/${GAMES_DATADIR}/${PN}
+
+ # setup high score file
+ insinto ${GAMES_STATEDIR}
+ insopts -m0664
+ doins pathological_scores
+
+ # documentation
+ dodoc README TODO
+ doman pathological.6.gz
+ use doc && dohtml -r html/
+
+ prepgamesdirs
+}