summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-19 00:08:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-19 00:08:20 +0000
commit10c06d33e184558cca439592e2bc616ff3a8fd92 (patch)
tree73717d3677a526fbd76103b9942e1bf7ddd01f12 /games-puzzle/monsterz
parentmore KEYWORDS for #68570 (diff)
downloadgentoo-2-10c06d33e184558cca439592e2bc616ff3a8fd92.tar.gz
gentoo-2-10c06d33e184558cca439592e2bc616ff3a8fd92.tar.bz2
gentoo-2-10c06d33e184558cca439592e2bc616ff3a8fd92.zip
initial import #84751
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/ChangeLog8
-rw-r--r--games-puzzle/monsterz/Manifest2
-rw-r--r--games-puzzle/monsterz/files/digest-monsterz-0.4.11
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.4.1-gentoo.patch24
-rw-r--r--games-puzzle/monsterz/metadata.xml5
-rw-r--r--games-puzzle/monsterz/monsterz-0.4.1.ebuild38
6 files changed, 78 insertions, 0 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
new file mode 100644
index 000000000000..83b5c01319ed
--- /dev/null
+++ b/games-puzzle/monsterz/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-puzzle/monsterz
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.1 2005/03/19 00:08:20 vapier Exp $
+
+*monsterz-0.4.1 (18 Mar 2005)
+
+ 18 Mar 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Julien Cayzac #84751.
diff --git a/games-puzzle/monsterz/Manifest b/games-puzzle/monsterz/Manifest
new file mode 100644
index 000000000000..d509e12dc330
--- /dev/null
+++ b/games-puzzle/monsterz/Manifest
@@ -0,0 +1,2 @@
+MD5 0eb0ccef7f72e64907ce4821d5736ea9 monsterz-0.4.1.ebuild 778
+MD5 48b4619fb74ecdcd08daf11d8bab2419 files/digest-monsterz-0.4.1 67
diff --git a/games-puzzle/monsterz/files/digest-monsterz-0.4.1 b/games-puzzle/monsterz/files/digest-monsterz-0.4.1
new file mode 100644
index 000000000000..1e0a1da628eb
--- /dev/null
+++ b/games-puzzle/monsterz/files/digest-monsterz-0.4.1
@@ -0,0 +1 @@
+MD5 829a2a34dfa819d6386fb4d64155e885 monsterz-0.4.1.tar.gz 2181022
diff --git a/games-puzzle/monsterz/files/monsterz-0.4.1-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.4.1-gentoo.patch
new file mode 100644
index 000000000000..5ab08f1c828b
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.4.1-gentoo.patch
@@ -0,0 +1,24 @@
+Touchup the paths so that the default isn't $PWD.
+
+--- monsterz.py
++++ monsterz.py
+@@ -1225,7 +1225,7 @@
+ print ' (C) 2002 Castles Music Productions <info@castlesmusic.co.nz>'
+ print ' (C) 1998 MenTaLguY <mental@rydia.net>'
+ print 'This is free software; you can redistribute it and/or modify it under the terms'
+- print 'of the Do What The Fuck You Want To Public License, Version 2, as published'
++ print 'of the WTFPL, Version 2, as published'
+ print 'by Sam Hocevar. See http://sam.zoy.org/projects/COPYING.WTFPL for more details.'
+
+ def usage():
+@@ -1247,8 +1247,8 @@
+ from getopt import getopt, GetoptError
+ global system, data, hiscores, fonter, monsterz
+ global FLAG_FULLSCREEN, FLAG_MUSIC, FLAG_SFX
+- sharedir = dirname(argv[0])
+- scorefile = join(sharedir, "scores")
++ sharedir = "GENTOO_DATADIR"
++ scorefile = "GENTOO_SCOREFILE"
+ outfd = None
+ try:
+ long = ['help', 'version', 'music', 'sound', 'fullscreen',
diff --git a/games-puzzle/monsterz/metadata.xml b/games-puzzle/monsterz/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/monsterz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/monsterz/monsterz-0.4.1.ebuild b/games-puzzle/monsterz/monsterz-0.4.1.ebuild
new file mode 100644
index 000000000000..e9293b15d12b
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.4.1.ebuild,v 1.1 2005/03/19 00:08:20 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/monsterz-0.4.1.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pygame"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ -e "s:GENTOO_SCOREFILE:${GAMES_STATEDIR}/${PN}.scores:" \
+ monsterz.py || die
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+ insinto ${dir}
+ doins *.wav *.s3m *.png || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "dobin failed"
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}"/${PN}.scores
+ dodoc README AUTHORS TODO INSTALL
+ prepgamesdirs
+ fperms g+w "${GAMES_STATEDIR}"/${PN}.scores
+}