summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-21 14:34:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-21 14:34:25 +0000
commit0ed3644f4a96d0f861c3e521d1e5f5df43e9d75a (patch)
tree8032eab3992beb805277de6973b3a99ba1447f49 /games-puzzle/jag/jag-0.3.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-0ed3644f4a96d0f861c3e521d1e5f5df43e9d75a.tar.gz
gentoo-2-0ed3644f4a96d0f861c3e521d1e5f5df43e9d75a.tar.bz2
gentoo-2-0ed3644f4a96d0f861c3e521d1e5f5df43e9d75a.zip
Version bump to 0.3.1 Bug #339376
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/jag/jag-0.3.1.ebuild')
-rw-r--r--games-puzzle/jag/jag-0.3.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/games-puzzle/jag/jag-0.3.1.ebuild b/games-puzzle/jag/jag-0.3.1.ebuild
new file mode 100644
index 000000000000..61f7a4ba5dd4
--- /dev/null
+++ b/games-puzzle/jag/jag-0.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/jag/jag-0.3.1.ebuild,v 1.1 2010/11/21 14:34:25 tupone Exp $
+
+EAPI=2
+inherit eutils qt4-r2 games
+
+DESCRIPTION="Arcade 2D Puzzle Game"
+HOMEPAGE="http://jag.xlabsoft.com/"
+SRC_URI="http://jag.xlabsoft.com/files/${P}-src.zip
+ http://jag.xlabsoft.com/files/jag_levels_sunzero.zip
+ extras? ( http://jag.xlabsoft.com/files/jag_seven_themes.zip )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="editor extras"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ x11-libs/libXrandr
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/local/bin:${GAMES_BINDIR}:g" \
+ -e "s:/usr/local/games:${GAMES_DATADIR}:g" \
+ -e "s:LIBS += -lSDLmain:LIBS += -lSDL:" \
+ Game.pro main.cpp editor/editor.pro \
+ || die "sed failed"
+}
+
+src_configure() {
+ qt4-r2_src_configure
+ if use editor; then
+ cd editor
+ eqmake4 editor.pro
+ fi
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use editor; then
+ cd editor
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon images/logo.png ${PN}.png
+ make_desktop_entry jag Jag
+
+ if use editor; then
+ cd editor
+ qt4-r2_src_install
+ make_desktop_entry jag-editor "Jag Level editor" ${PN}
+ cd ..
+ fi
+
+ insinto "${GAMES_DATADIR}/${PN}"/data/levels
+ doins -r "${WORKDIR}"/sunzero.lpk || die "doins failed"
+
+ if use extras; then
+ insinto "${GAMES_DATADIR}/${PN}"/data/schemes
+ doins -r "${WORKDIR}"/{african,animals,chinese,creatures,futurama,kde-nuvola,toys} || die "doins failed"
+ fi
+ prepgamesdirs
+}