summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-07-24 19:34:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-07-24 19:34:18 +0000
commit537712233ce2c168896676f21194b175c8452896 (patch)
treee0287f432b2bc15b529fca5d779cf4939344217f /games-misc
parentarm stable, bug #516654 (diff)
downloadgentoo-2-537712233ce2c168896676f21194b175c8452896.tar.gz
gentoo-2-537712233ce2c168896676f21194b175c8452896.tar.bz2
gentoo-2-537712233ce2c168896676f21194b175c8452896.zip
Fix build. Bug #514318
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/gtklife/ChangeLog8
-rw-r--r--games-misc/gtklife/files/gtklife-5.1-link.patch20
-rw-r--r--games-misc/gtklife/gtklife-5.1.ebuild18
3 files changed, 38 insertions, 8 deletions
diff --git a/games-misc/gtklife/ChangeLog b/games-misc/gtklife/ChangeLog
index 03ec0aadd555..a1152194b1c4 100644
--- a/games-misc/gtklife/ChangeLog
+++ b/games-misc/gtklife/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/gtklife
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gtklife/ChangeLog,v 1.16 2012/05/03 03:29:41 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gtklife/ChangeLog,v 1.17 2014/07/24 19:34:17 tupone Exp $
+
+ 24 Jul 2014; Tupone Alfredo <tupone@gentoo.org> gtklife-5.1.ebuild,
+ +files/gtklife-5.1-link.patch:
+ Fix build. Bug #514318 by Patrick Lauer
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gtklife-5.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-misc/gtklife/files/gtklife-5.1-link.patch b/games-misc/gtklife/files/gtklife-5.1-link.patch
new file mode 100644
index 000000000000..8aae429def1c
--- /dev/null
+++ b/games-misc/gtklife/files/gtklife-5.1-link.patch
@@ -0,0 +1,20 @@
+--- Makefile.in.old 2014-07-24 21:25:09.072431615 +0200
++++ Makefile.in 2014-07-24 21:26:34.898037740 +0200
+@@ -22,7 +22,7 @@
+ # Preprocessor and linking flags
+
+ CPPFLAGS:=$(CPPFLAGS) $(GTK_CFLAGS) -DVERSION=\"$(VERSION)\" -DDATADIR=\"$(pkgdatadir)\" -DDOCDIR=\"$(docdir)\"
+-LDFLAGS:=$(LDFLAGS) $(GTK_LIBS)
++LDLIBS:=$(GTK_LIBS) -lX11
+
+ # Object files
+
+@@ -51,7 +51,7 @@
+ $(INSTALL_DATA) doc/* $(docdir)
+
+ gtklife: $(OBJS)
+- $(CC) -o gtklife $(OBJS) $(LDFLAGS)
++ $(CC) -o gtklife $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+ create_lookup: $(CL_OBJS)
+ $(CC) -o create_lookup $(CL_OBJS)
diff --git a/games-misc/gtklife/gtklife-5.1.ebuild b/games-misc/gtklife/gtklife-5.1.ebuild
index 7c499f534a60..74df816f305f 100644
--- a/games-misc/gtklife/gtklife-5.1.ebuild
+++ b/games-misc/gtklife/gtklife-5.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gtklife/gtklife-5.1.ebuild,v 1.7 2012/05/03 03:29:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gtklife/gtklife-5.1.ebuild,v 1.8 2014/07/24 19:34:17 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils games
DESCRIPTION="A Conway's Life simulator for Unix"
@@ -14,10 +14,16 @@ SLOT="0"
KEYWORDS="amd64 hppa ~ppc x86"
IUSE=""
-RDEPEND="x11-libs/gtk+:2"
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ x11-libs/libX11"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-link.patch
+}
+
src_configure() {
egamesconf \
--with-gtk2 \
@@ -25,10 +31,10 @@ src_configure() {
}
src_install() {
- dogamesbin ${PN} || die "dogamesbin failed"
+ dogamesbin ${PN}
insinto "${GAMES_DATADIR}"/${PN}
- doins -r graphics patterns || die "doins failed"
+ doins -r graphics patterns
newicon icon_48x48.png ${PN}.png
make_desktop_entry ${PN} GtkLife