summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-09 18:44:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-09 18:44:51 +0000
commit487c1c68a344e745e6b10a51648328d781c4c287 (patch)
tree4635ced1f1b745c170cd6ed3bd432f5ca5c61640 /games-misc
parentInitial ebuild. (diff)
downloadgentoo-2-487c1c68a344e745e6b10a51648328d781c4c287.tar.gz
gentoo-2-487c1c68a344e745e6b10a51648328d781c4c287.tar.bz2
gentoo-2-487c1c68a344e745e6b10a51648328d781c4c287.zip
Cows tongue fixed, bug #177773
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/cowsay/ChangeLog8
-rw-r--r--games-misc/cowsay/cowsay-3.03-r1.ebuild41
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-tongue.patch10
-rw-r--r--games-misc/cowsay/files/digest-cowsay-3.03-r13
4 files changed, 61 insertions, 1 deletions
diff --git a/games-misc/cowsay/ChangeLog b/games-misc/cowsay/ChangeLog
index a2c32b03fcf7..f14b3a4cfa71 100644
--- a/games-misc/cowsay/ChangeLog
+++ b/games-misc/cowsay/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/cowsay
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.17 2007/02/28 18:42:21 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.18 2007/05/09 18:44:51 tupone Exp $
+
+*cowsay-3.03-r1 (09 May 2007)
+
+ 09 May 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/cowsay-3.03-tongue.patch, +cowsay-3.03-r1.ebuild:
+ Cows tongue fixed, bug #177773 by Dirk
28 Feb 2007; Peter Weller <welp@gentoo.org> cowsay-3.03.ebuild:
Keyworded x86-fbsd
diff --git a/games-misc/cowsay/cowsay-3.03-r1.ebuild b/games-misc/cowsay/cowsay-3.03-r1.ebuild
new file mode 100644
index 000000000000..91649ffe5035
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.03-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/cowsay-3.03-r1.ebuild,v 1.1 2007/05/09 18:44:51 tupone Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="configurable talking ASCII cow (and other characters)"
+HOMEPAGE="http://www.nog.net/~tony/warez/cowsay.shtml"
+SRC_URI="http://www.nog.net/~tony/warez/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '1 c\#!/usr/bin/perl'\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+ epatch "${FILESDIR}/${P}"-tongue.patch
+}
+
+src_install() {
+ dobin cowsay || die "dobin failed"
+ doman cowsay.1
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1 /usr/share/man/man1/cowthink.1
+ dodir /usr/share/${P}/cows
+ cp -r cows "${D}"/usr/share/${P}/ || die "cp failed"
+ dobashcompletion "${FILESDIR}"/${PN}.bashcomp
+}
diff --git a/games-misc/cowsay/files/cowsay-3.03-tongue.patch b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
new file mode 100644
index 000000000000..517e96709c23
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
@@ -0,0 +1,10 @@
+--- cows/head-in.cow.old 2007-05-09 20:28:08.000000000 +0200
++++ cows/head-in.cow 2007-05-09 20:29:32.000000000 +0200
+@@ -7,6 +7,6 @@
+ ^__^ /
+ ($eyes)\\_______/ _________
+ (__)\\ )=( ____|_ \\_____
+- $tongue ||----w | \\ \\ \\_____ |
++ $tongue ||----w | \\ \\ \\_____ |
+ || || || ||
+ EOC
diff --git a/games-misc/cowsay/files/digest-cowsay-3.03-r1 b/games-misc/cowsay/files/digest-cowsay-3.03-r1
new file mode 100644
index 000000000000..cce33ad5ee39
--- /dev/null
+++ b/games-misc/cowsay/files/digest-cowsay-3.03-r1
@@ -0,0 +1,3 @@
+MD5 b29169797359420dadb998079021a494 cowsay-3.03.tar.gz 15189
+RMD160 f26b9ffe3d5551ee8049979c628bbe198817044a cowsay-3.03.tar.gz 15189
+SHA256 0b8672a7ac2b51183780db72618b42af8ec1ce02f6c05fe612510b650540b2af cowsay-3.03.tar.gz 15189