summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 18:14:28 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 18:14:28 +0000
commit5185da51cd857a2dfde2d4b4705136834d5354e4 (patch)
tree751722dcc6f2f65f7839b89babf369c6a7de9fb3 /games-misc/gnurobots
parentstable on x86/alpha (diff)
downloadgentoo-2-5185da51cd857a2dfde2d4b4705136834d5354e4.tar.gz
gentoo-2-5185da51cd857a2dfde2d4b4705136834d5354e4.tar.bz2
gentoo-2-5185da51cd857a2dfde2d4b4705136834d5354e4.zip
games-misc
Diffstat (limited to 'games-misc/gnurobots')
-rw-r--r--games-misc/gnurobots/ChangeLog8
-rw-r--r--games-misc/gnurobots/Manifest3
-rw-r--r--games-misc/gnurobots/files/digest-gnurobots-1.0d1
-rw-r--r--games-misc/gnurobots/gnurobots-1.0d.ebuild38
4 files changed, 50 insertions, 0 deletions
diff --git a/games-misc/gnurobots/ChangeLog b/games-misc/gnurobots/ChangeLog
new file mode 100644
index 000000000000..08b695478e94
--- /dev/null
+++ b/games-misc/gnurobots/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/gnurobots
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/ChangeLog,v 1.1 2003/09/10 18:14:05 vapier Exp $
+
+*gnurobots-1.0d (22 Dec 2002)
+
+ 22 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Rigo Ketelings <rigo@home.nl>.
diff --git a/games-misc/gnurobots/Manifest b/games-misc/gnurobots/Manifest
new file mode 100644
index 000000000000..a70bfec67aff
--- /dev/null
+++ b/games-misc/gnurobots/Manifest
@@ -0,0 +1,3 @@
+MD5 09503bc71faa23895576b61e67509d13 ChangeLog 373
+MD5 3a69693ce344a208821dc373552f996a gnurobots-1.0d.ebuild 895
+MD5 de238cc8465c6cf347f48ddc94f9011e files/digest-gnurobots-1.0d 65
diff --git a/games-misc/gnurobots/files/digest-gnurobots-1.0d b/games-misc/gnurobots/files/digest-gnurobots-1.0d
new file mode 100644
index 000000000000..91692d0f2583
--- /dev/null
+++ b/games-misc/gnurobots/files/digest-gnurobots-1.0d
@@ -0,0 +1 @@
+MD5 0ced682367b0dc9b2fcfdb40230a5fb5 gnurobots-1.0D.tar.gz 71850
diff --git a/games-misc/gnurobots/gnurobots-1.0d.ebuild b/games-misc/gnurobots/gnurobots-1.0d.ebuild
new file mode 100644
index 000000000000..f9bb117e82f7
--- /dev/null
+++ b/games-misc/gnurobots/gnurobots-1.0d.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/gnurobots-1.0d.ebuild,v 1.1 2003/09/10 18:14:05 vapier Exp $
+
+inherit games
+
+MY_P="${PN}-${PV/d/D}"
+DESCRIPTION="Game/diversion where you construct a program for a little robot then set him loose and watch him explore a world on his own"
+HOMEPAGE="http://www.gnu.org/directory/games/gnurobots.html"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="X"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="X? ( virtual/x11 )
+ dev-util/guile"
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin src/{robots,xrobots,robots_logfile}
+
+ insinto ${GAMES_DATADIR}/${PN}/scheme
+ doins scheme/*.scm
+ insinto ${GAMES_DATADIR}/${PN}/maps
+ doins maps/*.map
+
+ dodoc doc/*
+
+ prepgamesdirs
+}