summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-06 09:24:38 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-06 09:24:38 +0000
commitb7a563fb27371bc5102b8ff99e14a0b23a9be14c (patch)
treed2820433445d99b08e477f08fa02ecf00268e608 /games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
parentVersion bump, fixing 'a lot of bugs' either in code or documentation; ArchLin... (diff)
downloadgentoo-2-b7a563fb27371bc5102b8ff99e14a0b23a9be14c.tar.gz
gentoo-2-b7a563fb27371bc5102b8ff99e14a0b23a9be14c.tar.bz2
gentoo-2-b7a563fb27371bc5102b8ff99e14a0b23a9be14c.zip
link against -lintl on non glibc systems when app-text/recode is built with nls, #184399.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
index 77104b436279..3313d46b967b 100644
--- a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.5 2006/07/20 08:08:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.6 2007/07/06 09:24:38 uberlord Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="offensive"
+IUSE="offensive elibc_glibc"
DEPEND="app-text/recode"
@@ -30,9 +30,11 @@ src_unpack() {
-e "/^OFFENSIVE=/s:=.*:=`use offensive && echo 1 || echo 0`:" \
Makefile || die "sed Makefile failed"
- if use elibc_FreeBSD ; then
+ if ! use elibc_glibc ; then
+ local reglibs="-lcompat"
+ built_with_use app-text/recode nls && reglibs="${reglibs} -lintl"
sed -i \
- -e '/^REGEXLIBS=/s:=.*:= -lcompat:' \
+ -e "/^REGEXLIBS=/s:=.*:= ${reglibs}:" \
Makefile \
|| die "sed REGEXLIBS failed"
fi