summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-22 18:05:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-22 18:05:20 +0000
commit881903e82d060d493eb85315722922ffe3fbda23 (patch)
tree9cde8e44c461bd4140f33c6669735889c8a1e25d /games-fps
parentBump for #380517 (diff)
downloadgentoo-2-881903e82d060d493eb85315722922ffe3fbda23.tar.gz
gentoo-2-881903e82d060d493eb85315722922ffe3fbda23.tar.bz2
gentoo-2-881903e82d060d493eb85315722922ffe3fbda23.zip
try to work around broken Makefiles (bug #383517)
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/ChangeLog5
-rw-r--r--games-fps/xonotic/xonotic-0.5.0.ebuild15
2 files changed, 12 insertions, 8 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 36275e4414ad..a9930666e341 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/xonotic
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.2 2011/09/22 18:05:20 mr_bones_ Exp $
+
+ 22 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org> xonotic-0.5.0.ebuild:
+ try to work around broken Makefiles (bug #383517)
*xonotic-0.5.0 (16 Sep 2011)
diff --git a/games-fps/xonotic/xonotic-0.5.0.ebuild b/games-fps/xonotic/xonotic-0.5.0.ebuild
index 721b16e465e4..0433b178b362 100644
--- a/games-fps/xonotic/xonotic-0.5.0.ebuild
+++ b/games-fps/xonotic/xonotic-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.5.0.ebuild,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.5.0.ebuild,v 1.2 2011/09/22 18:05:20 mr_bones_ Exp $
EAPI=2
inherit eutils check-reqs games
@@ -73,13 +73,14 @@ src_prepare() {
src_compile() {
local t="$(use debug && echo debug || echo release)"
+ local d
- emake \
- -C source/darkplaces \
- DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- sv-${t} \
- $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") \
- || die
+ for d in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})")
+ do
+ emake \
+ DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ -C source/darkplaces ${d} || die
+ done
}
src_install() {