summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-22 18:39:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-22 18:39:39 +0000
commit51dbefe179947fb1dba442add6622d543594061f (patch)
treefca67326cd7d9c7014fd3dc74e1d7e568fb3bc0b /games-fps
parentold (diff)
downloadgentoo-2-51dbefe179947fb1dba442add6622d543594061f.tar.gz
gentoo-2-51dbefe179947fb1dba442add6622d543594061f.tar.bz2
gentoo-2-51dbefe179947fb1dba442add6622d543594061f.zip
declutter
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/darkplaces/ChangeLog6
-rw-r--r--games-fps/darkplaces/darkplaces-20121222.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/games-fps/darkplaces/ChangeLog b/games-fps/darkplaces/ChangeLog
index d6ca181dbcb4..e5bae7327e7a 100644
--- a/games-fps/darkplaces/ChangeLog
+++ b/games-fps/darkplaces/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/darkplaces
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/ChangeLog,v 1.17 2013/01/22 18:33:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/ChangeLog,v 1.18 2013/01/22 18:39:39 mr_bones_ Exp $
+
+ 22 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ darkplaces-20121222.ebuild:
+ declutter
22 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-darkplaces-20100408.ebuild:
diff --git a/games-fps/darkplaces/darkplaces-20121222.ebuild b/games-fps/darkplaces/darkplaces-20121222.ebuild
index 6eeea4d3b50a..bb1c43848f94 100644
--- a/games-fps/darkplaces/darkplaces-20121222.ebuild
+++ b/games-fps/darkplaces/darkplaces-20121222.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20121222.ebuild,v 1.1 2013/01/14 18:40:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20121222.ebuild,v 1.2 2013/01/22 18:39:39 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -69,7 +69,7 @@ opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
src_unpack() {
if use lights ; then
unpack "${MY_LIGHTS}"
- unzip -qo "${DISTDIR}"/id1.pk3 || die "unzip id1.pk3 failed"
+ unzip -qo "${DISTDIR}"/id1.pk3 || die
mv *.lit maps/ || die
mv ReadMe.txt rtlights.txt
fi
@@ -95,16 +95,16 @@ src_prepare() {
-e '/^LDFLAGS_DEBUG/s/$/ $(LDFLAGS)/' \
-e '/^LDFLAGS_RELEASE/s/$/ $(LDFLAGS)/' \
-e "s:strip:true:" \
- makefile.inc || die "sed makefile.inc failed"
+ makefile.inc || die
if ! use cdsound ; then
# Turn the CD accesses off
sed -i \
-e "s:/dev/cdrom:/dev/null:" \
- cd_linux.c || die "sed cd_linux.c failed"
+ cd_linux.c || die
sed -i \
-e 's:COM_CheckParm("-nocdaudio"):1:' \
- cd_shared.c || die "sed cd_shared.c failed"
+ cd_shared.c || die
fi
}
@@ -122,13 +122,13 @@ src_compile() {
# Only compile a maximum of 1 client
if use sdl ; then
- emake ${opts} "sdl-${type}" || die "emake sdl-${type} failed"
+ emake ${opts} "sdl-${type}" || die
elif opengl_client ; then
- emake ${opts} "cl-${type}" || die "emake cl-${type} failed"
+ emake ${opts} "cl-${type}" || die
fi
if use dedicated ; then
- emake ${opts} "sv-${type}" || die "emake sv-${type} failed"
+ emake ${opts} "sv-${type}" || die
fi
}
@@ -139,8 +139,8 @@ src_install() {
use sdl && type=sdl
# darkplaces executable is needed, even just for demo
- newgamesbin "${PN}-${type}" ${PN} || die "newgamesbin client failed"
- newicon darkplaces72x72.png ${PN}.png || die "newicon failed"
+ newgamesbin "${PN}-${type}" ${PN} || die
+ newicon darkplaces72x72.png ${PN}.png || die
if use demo ; then
# Install command-line for demo, even if not desktop entry
@@ -156,14 +156,14 @@ src_install() {
fi
if use dedicated ; then
- newgamesbin ${PN}-dedicated ${PN}-ded || die "newgamesbin ded failed"
+ newgamesbin ${PN}-dedicated ${PN}-ded || die
fi
dodoc *.txt ChangeLog todo "${WORKDIR}"/*.txt
if use lights ; then
insinto "${dir}"/id1
- doins -r "${WORKDIR}"/{cubemaps,maps} || die "doins cubemaps maps failed"
+ doins -r "${WORKDIR}"/{cubemaps,maps} || die
if use demo ; then
# Set up symlinks, for the demo levels to include the lights
local d