summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-04-01 20:04:47 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-04-01 20:04:47 +0000
commit46ece4372370fa48eeab1d35b82f8322e3a8b6dd (patch)
tree50af6f559307be4a6fd9f0b75fa01312706a98cc /games-fps
parentdev-libs/libcec new ebuild. (diff)
downloadgentoo-2-46ece4372370fa48eeab1d35b82f8322e3a8b6dd.tar.gz
gentoo-2-46ece4372370fa48eeab1d35b82f8322e3a8b6dd.tar.bz2
gentoo-2-46ece4372370fa48eeab1d35b82f8322e3a8b6dd.zip
Enable software rasterizer on amd64. From bug #358955
(Portage version: 2.1.10.52/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog6
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_soft.patch45
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild3
3 files changed, 52 insertions, 2 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index b03d012f7586..f1dbe3f0f144 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.44 2012/04/01 17:08:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.45 2012/04/01 20:04:46 tupone Exp $
+
+ 01 Apr 2012; Tupone Alfredo <tupone@gentoo.org>
+ quake2-icculus-0.16.1-r1.ebuild, +files/quake2-icculus-0.16.1-x11_soft.patch:
+ Enable software rasterizer on amd64. From bug #358955 by ocrbj
01 Apr 2012; Tupone Alfredo <tupone@gentoo.org>
quake2-icculus-0.16.1-r1.ebuild,
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_soft.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_soft.patch
new file mode 100644
index 000000000000..e23caf9db09f
--- /dev/null
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_soft.patch
@@ -0,0 +1,45 @@
+
+the x11 software renderer just needs some tweaks to get working
+
+--- Makefile.old
++++ Makefile
+@@ -358,7 +358,7 @@
+ endif
+
+ ifeq ($(strip $(BUILD_X11)),YES)
+- $(warning Warning: Software X Renderer not supported for $(ARCH))
++ TARGETS += $(BUILDDIR)/ref_softx.$(SHLIBEXT)
+ endif
+
+ ifeq ($(strip $(BUILD_GLX)),YES)
+--- src/linux/rw_x11.c.old
++++ src/linux/rw_x11.c
+@@ -53,7 +53,7 @@
+ #include <X11/Xatom.h>
+ #include <X11/keysym.h>
+ #include <X11/extensions/XShm.h>
+-#include <X11/extensions/xf86dga.h>
++#include <X11/extensions/Xxf86dga.h>
+ #ifdef OPENGL
+ #include <X11/extensions/xf86vmode.h>
+ #endif
+@@ -151,7 +151,7 @@
+ int config_notify_height;
+
+ typedef unsigned short PIXEL16;
+-typedef unsigned long PIXEL24;
++typedef unsigned int PIXEL24;
+ #ifdef REDBLUE
+ static PIXEL16 st2d_8to16table_s[2][256];
+ static PIXEL24 st2d_8to24table_s[2][256];
+--- src/ref_soft/r_poly.c.old
++++ src/ref_soft/r_poly.c
+@@ -994,7 +994,7 @@
+ scale = yscale * pout->zi;
+ pout->v = (ycenter - scale * transformed[1]);
+
+- pv += sizeof (vec5_t) / sizeof (pv);
++ pv += sizeof (vec5_t) / sizeof (float);
+ }
+
+ // draw it
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index 5663f4cf5ad6..e037424665a9 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.25 2012/04/01 17:08:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.26 2012/04/01 20:04:46 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -81,6 +81,7 @@ src_prepare() {
"${FILESDIR}"/${P}-ldflags.patch \
"${FILESDIR}"/${P}-no-asm-io.patch \
"${FILESDIR}"/${P}-gnusource.patch \
+ "${FILESDIR}"/${P}-x11_soft.patch \
"${FILESDIR}"/${P}-alsa.patch
if use xatrix ; then