summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-16 09:40:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-16 09:40:51 +0000
commit7dc8b784ca1176905ad835d8015aedad5474e3d2 (patch)
tree0eac1facd8eda4684b9c4956ad2e2ec067b786ed /games-fps/xonotic
parentrm old (diff)
downloadgentoo-2-7dc8b784ca1176905ad835d8015aedad5474e3d2.tar.gz
gentoo-2-7dc8b784ca1176905ad835d8015aedad5474e3d2.tar.bz2
gentoo-2-7dc8b784ca1176905ad835d8015aedad5474e3d2.zip
version bump (bug # 536748)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/ChangeLog9
-rw-r--r--games-fps/xonotic/xonotic-0.8.0.ebuild114
2 files changed, 121 insertions, 2 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 88500303d7ca..4475d41bccf8 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/xonotic
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.16 2014/11/15 07:11:13 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.17 2015/01/16 09:40:51 mr_bones_ Exp $
+
+*xonotic-0.8.0 (16 Jan 2015)
+
+ 16 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +xonotic-0.8.0.ebuild:
+ version bump (bug # 536748)
15 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org> -xonotic-0.6.0.ebuild:
old
diff --git a/games-fps/xonotic/xonotic-0.8.0.ebuild b/games-fps/xonotic/xonotic-0.8.0.ebuild
new file mode 100644
index 000000000000..2dd630a2c20f
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.8.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.8.0.ebuild,v 1.1 2015/01/16 09:40:51 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils check-reqs games
+
+MY_PN="${PN^}"
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="http://www.xonotic.org/"
+SRC_URI="http://dl.xonotic.org/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dedicated doc sdl"
+
+UIRDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/libmodplug
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ virtual/opengl
+ media-libs/freetype:2
+ alsa? ( media-libs/alsa-lib )
+ sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
+UIDEPEND="
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ media-libs/libpng
+ net-misc/curl
+ ~dev-libs/d0_blind_id-0.5
+ !dedicated? ( ${UIRDEPEND} )"
+DEPEND="${RDEPEND}
+ !dedicated? ( ${UIDEPEND} )"
+
+CHECKREQS_DISK_BUILD="1200M"
+CHECKREQS_DISK_USR="950M"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ check-reqs_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^EXE_/s:darkplaces:${PN}:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e '/^STRIP/s/strip/true/' \
+ source/darkplaces/makefile.inc || die
+
+ if ! use alsa; then
+ sed -i \
+ -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
+ source/darkplaces/makefile || die
+ fi
+}
+
+src_compile() {
+ local t="$(use debug && echo debug || echo release)"
+ local i
+
+ # use a for-loop wrt bug 473352
+ for i in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") ; do
+ emake \
+ -C source/darkplaces \
+ DP_LINK_TO_LIBJPEG=1 \
+ DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ ${i}
+ done
+}
+
+src_install() {
+ if ! use dedicated; then
+ dogamesbin source/darkplaces/${PN}-glx
+ newicon misc/logos/${PN}_icon.svg ${PN}.svg
+ make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
+
+ if use sdl; then
+ dogamesbin source/darkplaces/${PN}-sdl
+ make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
+ fi
+ fi
+ dogamesbin source/darkplaces/${PN}-dedicated
+
+ dodoc Docs/*.txt
+ use doc && dohtml -r Docs
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r key_0.d0pk server data
+ prepgamesdirs
+
+ elog "If you are using opensource drivers you should consider installing: "
+ elog " media-libs/libtxc_dxtn"
+}