summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-07 22:03:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-07 22:03:55 +0000
commit59546662d282fc516ae182a2c2c282c617c860a6 (patch)
tree0a29a2dcd6850eb0c0e415ddd35039c052e3b7fa /games-fps/warsow
parentAnother patch to fix bug #202561. (diff)
downloadgentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.tar.gz
gentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.tar.bz2
gentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps/warsow')
-rw-r--r--games-fps/warsow/files/warsow-0.3.2-build.patch37
-rw-r--r--games-fps/warsow/files/warsow-0.3.2-mapdl.patch11
-rw-r--r--games-fps/warsow/warsow-0.3.2-r1.ebuild106
3 files changed, 0 insertions, 154 deletions
diff --git a/games-fps/warsow/files/warsow-0.3.2-build.patch b/games-fps/warsow/files/warsow-0.3.2-build.patch
deleted file mode 100644
index 86510a42de7a..000000000000
--- a/games-fps/warsow/files/warsow-0.3.2-build.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- source/Makefile
-+++ source/Makefile
-@@ -100,9 +100,9 @@
- LOCALBASE?=/usr/local
- X11BASE?=/usr/X11R6
-
--CFLAGS_COMMON=$(CFLAGS) -I. -I$(LOCALBASE)/include -I$(X11BASE)/include -Wall
--CFLAGS_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops -DNDEBUG
--CFLAGS_DEBUG=-O0 -ggdb -D_DEBUG
-+CFLAGS_COMMON=$(CFLAGS) -I. -fno-strict-aliasing -Wall
-+CFLAGS_RELEASE=-DNDEBUG
-+CFLAGS_DEBUG=-D_DEBUG
- ifeq ($(DEBUG_BUILD),YES)
- CFLAGS_COMMON+=$(CFLAGS_DEBUG)
- else
-@@ -116,7 +116,7 @@
- ifeq ($(OS),FreeBSD)
- LDFLAGS_COMMON=-L/usr/local/lib -lm
- else
--LDFLAGS_COMMON=-L/usr/local/lib -ldl -lm
-+LDFLAGS_COMMON=$(LDFLAGS) -ldl -lm
- endif
-
- ifeq ($(ARCH),x86_64)
-@@ -287,10 +287,10 @@
-
- all: client openal qf ded cgame game ui irc
-
--client: $(BUILDDIRS) message-client compile-client link-client start-script-client
-+client: $(BUILDDIRS) message-client compile-client link-client
- openal: $(BUILDDIRS) message-openal compile-openal link-openal
- qf: $(BUILDDIRS) message-qf compile-qf link-qf
--ded: $(BUILDDIRS) message-ded compile-ded link-ded start-script-ded
-+ded: $(BUILDDIRS) message-ded compile-ded link-ded
- cgame: $(BUILDDIRS) message-cgame compile-cgame link-cgame
- game: $(BUILDDIRS) message-game compile-game link-game
- ui: $(BUILDDIRS) message-ui compile-ui link-ui
diff --git a/games-fps/warsow/files/warsow-0.3.2-mapdl.patch b/games-fps/warsow/files/warsow-0.3.2-mapdl.patch
deleted file mode 100644
index fcbe76597119..000000000000
--- a/games-fps/warsow/files/warsow-0.3.2-mapdl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- warsow-0.32/warsow_0.32/source/qcommon/files.c 2007-08-07 17:47:31.000000000 +0200
-+++ warsow-0.32.fixed/warsow_0.32/source/qcommon/files.c 2007-09-27 04:42:09.000000000 +0200
-@@ -2277,7 +2277,7 @@
- if( !fullname )
- return qfalse;
-
-- pakfile = FS_LoadPK3File( filename, qtrue );
-+ pakfile = FS_LoadPK3File( fullname, qtrue );
- if( pakfile ) { // unlock and free, we don't need this file anyway
- if( pakfile->sysHandle )
- Sys_FS_UnlockFile( pakfile->sysHandle );
diff --git a/games-fps/warsow/warsow-0.3.2-r1.ebuild b/games-fps/warsow/warsow-0.3.2-r1.ebuild
deleted file mode 100644
index 18edd8ff742e..000000000000
--- a/games-fps/warsow/warsow-0.3.2-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.3.2-r1.ebuild,v 1.4 2008/01/18 03:09:29 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs versionator games
-
-MY_P=${PN}_$(delete_version_separator 2)
-DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
-HOMEPAGE="http://www.warsow.net/"
-SRC_URI="http://www.megami.de/warsow/releases/${MY_P}_linux.tar.gz
- http://www.megami.de/warsow/releases/${MY_P}_sdk.zip
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug dedicated irc openal opengl"
-
-UIRDEPEND="media-libs/jpeg
- media-libs/libvorbis
- media-libs/libsdl
- net-misc/curl
- virtual/opengl
- x11-libs/libXinerama
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- openal? ( media-libs/openal )"
-RDEPEND="opengl? ( ${UIRDEPEND} )
- !opengl? ( !dedicated? ( ${UIRDEPEND} ) )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-proto/xf86dgaproto
- x11-misc/makedepend"
-
-S=${WORKDIR}/${MY_P}/source
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm -f "${WORKDIR}"/${PN}/docs/gnu.txt
-
- sed -i \
- -e '/fs_usehomedir =/ s:0:1:' \
- -e "/fs_basepath =/ s:\.:${GAMES_DATADIR}/${PN}:" \
- qcommon/files.c \
- || die "sed files.c failed"
-
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-mapdl.patch
-}
-
-src_compile() {
- yesno() { use ${1} && echo YES || echo NO ; }
-
- if use opengl || ! use dedicated ; then
- local client="YES"
- else
- local client="NO"
- fi
-
- emake \
- BUILD_CLIENT=${client} \
- BUILD_SERVER=$(yesno dedicated) \
- BUILD_IRC=$(yesno irc) \
- BUILD_SND_OPENAL=$(yesno openal) \
- DEBUG_BUILD=$(yesno debug) \
- CC="$(tc-getCC)" \
- LD="$(tc-getCC)" \
- || die "emake failed"
-}
-
-src_install() {
- cd release
-
- if use opengl || ! use dedicated ; then
- newgamesbin ${PN}.* ${PN} || die "newgamesbin ${PN} failed"
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} Warsow
- fi
-
- if use dedicated ; then
- newgamesbin wsw_server.* ${PN}-ded || die "newgamesbin ${PN}-ded failed"
- fi
-
- exeinto "$(games_get_libdir)"/${PN}
- doexe */*.so || die "doexe failed"
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${WORKDIR}"/${PN}/basewsw || die "doins failed"
-
- local so
- for so in basewsw/*.so ; do
- dosym "$(games_get_libdir)"/${PN}/${so##*/} \
- "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
- done
-
- dodir "${GAMES_DATADIR}"/${PN}/libs
- for so in libs/*.so ; do
- dosym "$(games_get_libdir)"/${PN}/${so##*/} \
- "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
- done
-
- dodoc "${WORKDIR}"{/${PN},}/docs/*
- prepgamesdirs
-}