summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2003-12-06 15:06:28 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2003-12-06 15:06:28 +0000
commit617a3a8bb85f167269c55b5cdd723c7f27188f0d (patch)
tree47864fa8c942847bb48e2837b0ae0246b9efeaeb /games-fps/quake3
parentBumped version to newest revision. Closing Bug #35178. (diff)
downloadgentoo-2-617a3a8bb85f167269c55b5cdd723c7f27188f0d.tar.gz
gentoo-2-617a3a8bb85f167269c55b5cdd723c7f27188f0d.tar.bz2
gentoo-2-617a3a8bb85f167269c55b5cdd723c7f27188f0d.zip
Bumped version to newest revision. Closing Bug #35178.
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog7
-rw-r--r--games-fps/quake3/Manifest4
-rw-r--r--games-fps/quake3/files/digest-quake3-1.32b-r31
-rw-r--r--games-fps/quake3/quake3-1.32b-r3.ebuild72
4 files changed, 81 insertions, 3 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 9414426ed976..1fca98a0cada 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake3
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.4 2003/10/05 02:23:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.5 2003/12/06 15:06:15 wolf31o2 Exp $
+
+*quake3-1.32b-r3 (06 Dec 2003)
+
+ 06 Dec 2003; Chris Gianelloni <wolf31o2@gentoo.org> quake3-1.32b-r3.ebuild:
+ Bumped version to newest revision. Closing Bug #35178.
05 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org> quake3-1.32b.ebuild:
Updated to use games user, make a desktop entry, and added to description
diff --git a/games-fps/quake3/Manifest b/games-fps/quake3/Manifest
index d35a401304f9..6d6429e8055b 100644
--- a/games-fps/quake3/Manifest
+++ b/games-fps/quake3/Manifest
@@ -1,6 +1,6 @@
MD5 e861a4fc910fe4f443d12f1f9c2885dc quake3-1.32b.ebuild 1782
-MD5 039a7844a7c8cc087eb15e2e22996cd4 quake3-1.32b-r3.ebuild 1790
-MD5 229ae5f58517e83fcc7504c00aa8b7e6 ChangeLog 1390
+MD5 dfc51827caa29c396d2669bf086640b7 quake3-1.32b-r3.ebuild 1795
+MD5 908b02f591b55f7a3dd28c4cf2e25df0 ChangeLog 1561
MD5 7a7f02df761b544f6301991232bdc597 metadata.xml 1005
MD5 fb8605f2e87b0cb33190a6e70b563483 quake3-1.31.ebuild 1515
MD5 3406e5aa779153f1890c48a2adfe13ce files/q3ded.rc 448
diff --git a/games-fps/quake3/files/digest-quake3-1.32b-r3 b/games-fps/quake3/files/digest-quake3-1.32b-r3
new file mode 100644
index 000000000000..9a97af6bbece
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.32b-r3
@@ -0,0 +1 @@
+MD5 c71fdddccb20e8fc393d846e9c61d685 linuxq3apoint-1.32b-3.x86.run 30923961
diff --git a/games-fps/quake3/quake3-1.32b-r3.ebuild b/games-fps/quake3/quake3-1.32b-r3.ebuild
new file mode 100644
index 000000000000..eaa0d6984db3
--- /dev/null
+++ b/games-fps/quake3/quake3-1.32b-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.32b-r3.ebuild,v 1.1 2003/12/06 15:06:16 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-${PV}-3.x86.run"
+
+LICENSE="Q3AEULA"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="${IUSE} X opengl"
+RESTRICT="nostrip"
+
+RDEPEND="virtual/glibc
+ opengl? ( virtual/opengl )
+ X? ( virtual/x11 )
+ dedicated? ( app-misc/screen )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ insinto ${dir}/baseq3
+ doins baseq3/*.pk3
+ mv Docs ${D}/${dir}/
+ insinto ${dir}/missionpack
+ doins missionpack/*.pk3
+ mv pb ${D}/${dir}/
+
+ exeinto ${dir}
+ insinto ${dir}
+ doexe bin/Linux/x86/{quake3.x86,q3ded} ${FILESDIR}/startq3ded
+ doins quake3.xpm README* Q3A_EULA.txt
+ dogamesbin ${FILESDIR}/quake3 ${FILESDIR}/q3ded
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/q3ded.rc q3ded
+ insinto /usr/share/pixmaps
+ doins quake3.xpm
+
+ prepgamesdirs
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # Shouldn't this be using the games user?
+ # enewuser q3 -1 /bin/bash /opt/quake3 ${GAMES_GROUP}
+
+ einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
+ einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
+ echo
+ einfo "To start a dedicated server, run"
+ einfo "\t/etc/init.d/q3ded start"
+ echo
+ einfo "The dedicated server is started under the ${GAMES_USER_DED} user account."
+}