summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-27 20:41:42 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-27 20:41:42 +0000
commit95eb71ae45042f71c974fc48c2009d3774b2cd7b (patch)
treef2a62861facddeb6b7a6c157ccdb719359a0b129 /games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
parentAdded license for games-fps/quake2-demodata. (diff)
downloadgentoo-2-95eb71ae45042f71c974fc48c2009d3774b2cd7b.tar.gz
gentoo-2-95eb71ae45042f71c974fc48c2009d3774b2cd7b.tar.bz2
gentoo-2-95eb71ae45042f71c974fc48c2009d3774b2cd7b.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #137519.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'games-fps/quake2-demodata/quake2-demodata-3.14.ebuild')
-rw-r--r--games-fps/quake2-demodata/quake2-demodata-3.14.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
new file mode 100644
index 000000000000..1b778ad77d42
--- /dev/null
+++ b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild,v 1.1 2006/06/27 20:41:42 wolf31o2 Exp $
+
+inherit eutils versionator games
+
+MY_PV=$(delete_all_version_separators)
+MY_PN="quake2"
+FILE="q2-${MY_PV}-demo-x86.exe"
+
+DESCRIPTION="Demo data for Quake 2"
+HOMEPAGE="http://en.wikipedia.org/wiki/Quake_II"
+SRC_URI="mirror://idsoftware/${MY_PN}/${FILE}"
+
+# See license.txt - it's a bit different to Q2EULA in Portage
+LICENSE="quake2-demodata"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${MY_PN}
+
+pkg_setup() {
+ games_pkg_setup
+
+ local alert_user
+
+ if ! use symlink ; then
+ ewarn "The 'symlink' USE flag is needed for Quake 2 clients"
+ ewarn "to easily play the demo data."
+ echo
+ alert_user=y
+ fi
+
+ if has_version "games-fps/quake2-data" ; then
+ ewarn "games-fps/quake2-data already includes the demo data,"
+ ewarn "so this installation is not very useful."
+ echo
+ if use symlink ; then
+ eerror "The symlink for the demo data conflicts with the cdinstall data"
+ die "Remove the 'symlink' USE flag for this package"
+ fi
+ alert_user=y
+ fi
+
+ if [[ -n "${alert_user}" ]] ; then
+ ebeep
+ epause
+ fi
+}
+
+src_unpack() {
+ unzip -qo "${DISTDIR}/${FILE}" || die "unzip failed"
+}
+
+src_install() {
+ insinto "${dir}"/demo
+ doins -r Install/Data/baseq2/{pak0.pak,players} || die "doins pak players failed"
+
+ dodoc Install/Data/DOCS/*.txt
+
+ if use symlink ; then
+ # Make the demo the default, so that people can just run it,
+ # without having to mess with command-line options.
+ cd "${D}/${dir}" && ln -sfn demo baseq2
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "This is just the demo data. To play, install a client"
+ einfo "such as games-fps/qudos"
+ echo
+
+ if use symlink ; then
+ einfo "baseq2 has been symlinked to demo, for convenience, within:"
+ einfo "${dir}"
+ echo
+ fi
+}