summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-05 22:38:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-05 22:38:41 +0000
commit20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4 (patch)
tree94f16fc0e3fcb59a23cd9fcb00a8904ff06b6a6c /games-fps/anaglyph-stereo-quake
parentadd support for existing installs/ultimate quake by UncleOwen #111615 (diff)
downloadgentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.tar.gz
gentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.tar.bz2
gentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.zip
quake-data -> quake1 #111622
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps/anaglyph-stereo-quake')
-rw-r--r--games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
index f3c5f523b0d9..4c0095051052 100644
--- a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
+++ b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.10 2005/09/26 18:02:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.11 2005/11/05 22:33:53 vapier Exp $
inherit eutils games
@@ -25,32 +25,32 @@ S=${WORKDIR}/WinQuake
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mv GLQUAKE.H glquake.h
mv GL_DRAW.C gl_draw.c
mv GL_RMAIN.C gl_rmain.c
- epatch ${FILESDIR}/stupid-dosformat.patch
+ epatch "${FILESDIR}"/stupid-dosformat.patch
mv Makefile{.linuxi386,}
- epatch ${FILESDIR}/makefile-path-fixes.patch
- epatch ${FILESDIR}/fix-sys_printf.patch
- epatch ${FILESDIR}/makefile-cflags.patch
- epatch ${FILESDIR}/gentoo-paths.patch
- edos2unix console.c ${WORKDIR}/${P}-SDL.patch
- epatch ${WORKDIR}/${P}-SDL.patch
- epatch ${FILESDIR}/${P}-amd64.patch
+ epatch "${FILESDIR}"/makefile-path-fixes.patch
+ epatch "${FILESDIR}"/fix-sys_printf.patch
+ epatch "${FILESDIR}"/makefile-cflags.patch
+ epatch "${FILESDIR}"/gentoo-paths.patch
+ edos2unix console.c "${WORKDIR}"/${P}-SDL.patch
+ epatch "${WORKDIR}"/${P}-SDL.patch
+ epatch "${FILESDIR}"/${P}-amd64.patch
}
src_compile() {
make \
OPTFLAGS="${CFLAGS}" \
- GENTOO_DATADIR=${GAMES_DATADIR}/quake-data \
+ GENTOO_DATADIR=${GAMES_DATADIR}/quake1 \
build_release \
|| die "failed to build WinQuake"
}
src_install() {
- newgamesbin release*/bin/glquake.sdl anaglyph-stereo-quake
- dodoc ${WORKDIR}/readme.id.txt
- dohtml ${WORKDIR}/3dquake.html
+ newgamesbin release*/bin/glquake.sdl anaglyph-stereo-quake || die
+ dodoc "${WORKDIR}"/readme.id.txt
+ dohtml "${WORKDIR}"/3dquake.html
prepgamesdirs
}