summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2012-05-07 13:38:04 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2012-05-07 13:38:04 +0000
commit7c040973d806d6c2bb7570f2a8da6113bfde871e (patch)
treec48b5a6ca0c10b1276a71b5fffeaccc5be92edc5 /games-engines
parentSecurity bump (bug #414963). Removed old (diff)
downloadgentoo-2-7c040973d806d6c2bb7570f2a8da6113bfde871e.tar.gz
gentoo-2-7c040973d806d6c2bb7570f2a8da6113bfde871e.tar.bz2
gentoo-2-7c040973d806d6c2bb7570f2a8da6113bfde871e.zip
Version bump. Closes bug #398535.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/gargoyle/ChangeLog7
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1.ebuild97
2 files changed, 103 insertions, 1 deletions
diff --git a/games-engines/gargoyle/ChangeLog b/games-engines/gargoyle/ChangeLog
index 7ee59387b36f..cde10b656f31 100644
--- a/games-engines/gargoyle/ChangeLog
+++ b/games-engines/gargoyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/gargoyle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.15 2012/05/04 15:01:10 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.16 2012/05/07 13:38:04 s4t4n Exp $
+
+*gargoyle-2010.1 (04 May 2012)
+
+ 07 May 2012; Michele Noberasco <s4t4n@gentoo.org> gargoyle-2011.1.ebuild:
+ Version bump. Closes bug #398535.
*gargoyle-2010.1 (04 May 2012)
diff --git a/games-engines/gargoyle/gargoyle-2011.1.ebuild b/games-engines/gargoyle/gargoyle-2011.1.ebuild
new file mode 100644
index 000000000000..a92cbf11d1d3
--- /dev/null
+++ b/games-engines/gargoyle/gargoyle-2011.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.1 2012/05/07 13:38:04 s4t4n Exp $
+
+# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
+# interpreters are licensed under GPLv2, BSD or MIT license, except:
+# - glulxe: custom license, see "terps/glulxle/README"
+# - hugo: custom license, see "licenses/HUGO License.txt"
+# Since we don't compile or install any of the bundled fonts, their licenses
+# don't apply. (Fonts are installed through dependencies instead.)
+
+EAPI=3
+
+inherit eutils games
+
+DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
+HOMEPAGE="http://ccxvii.net/gargoyle/"
+SRC_URI="http://garglk.googlecode.com/files/${P}-sources.zip"
+
+LICENSE="BSD GPL-2 MIT Hugo Glulxe"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freetype:2
+ virtual/jpeg
+ media-libs/libpng
+ media-fonts/liberation-fonts
+ >=media-fonts/libertine-ttf-5
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ media-libs/sdl-mixer
+ media-libs/sdl-sound[modplug,mp3,vorbis]"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/ftjam"
+
+src_prepare() {
+ # Substitute custom CFLAGS/LDFLAGS.
+ sed -i -e \
+ "/^\s*OPTIM = / {
+ s/ \(-O.*\)\? ;/ ${CFLAGS} ;/
+ a LINKFLAGS = ${LDFLAGS} ;
+ a SHRLINKFLAGS = ${LDFLAGS} ;
+ }" Jamrules || die
+
+ # Don't link against libraries used indirectly through SDL_sound.
+ sed -i -e "/GARGLKLIBS/s/-lsmpeg -lvorbisfile//g" Jamrules
+
+ # Convert garglk.ini to UNIX format.
+ edos2unix garglk/garglk.ini
+
+ # The font name of Linux Libertine changed in version 5.
+ sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini
+}
+
+src_compile() {
+ jam \
+ -sGARGLKINI="${GAMES_SYSCONFDIR}/garglk.ini" \
+ -sUSESDL=yes \
+ -sBUNDLEFONTS=no \
+ -j$(makeopts_jobs) || die
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ _BINDIR="${GAMES_PREFIX}/libexec/${PN}" \
+ _APPDIR="${GAMES_PREFIX}/libexec/${PN}" \
+ _LIBDIR="$(games_get_libdir)" \
+ EXEMODE=755 \
+ FILEMODE=755 \
+ jam install || die
+
+ # Install config file.
+ insinto "${GAMES_SYSCONFDIR}"
+ newins garglk/garglk.ini garglk.ini || die
+
+ # Install application entry and icon.
+ insinto /usr/share/applications
+ doins garglk/${PN}.desktop || die
+ doicon garglk/${PN}-house.png || die
+
+ # Symlink binaries to avoid name clashes.
+ for terp in advsys agility alan2 alan3 frotz geas git glulxe hugo jacl \
+ level9 magnetic nitfol scare tadsr
+ do
+ dosym "${GAMES_PREFIX}/libexec/${PN}/${terp}" \
+ "${GAMES_BINDIR}/${PN}-${terp}" || die
+ done
+
+ # Also symlink the main binary since it resides in libexec.
+ dosym "${GAMES_PREFIX}/libexec/${PN}/${PN}" \
+ "${GAMES_BINDIR}/${PN}" || die
+
+ prepgamesdirs
+}