summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-09 21:53:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-09 21:53:24 +0000
commit7b91a204fe269536c8e0890b3197370650e58e72 (patch)
tree5ff640b44985bd0bffd317c5b7466ad785bfdaea /games-engines
parentRestore version needed by dev-python/hacking. (diff)
downloadgentoo-2-7b91a204fe269536c8e0890b3197370650e58e72.tar.gz
gentoo-2-7b91a204fe269536c8e0890b3197370650e58e72.tar.bz2
gentoo-2-7b91a204fe269536c8e0890b3197370650e58e72.zip
fix install (bug #542560)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog6
-rw-r--r--games-engines/scummvm-tools/files/scummvm-tools-1.7.0-binprefix.patch11
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild9
3 files changed, 20 insertions, 6 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index a3ada7da2c9c..a6bab11982b1 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.66 2015/02/19 06:22:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.67 2015/03/09 21:53:24 mr_bones_ Exp $
+
+ 09 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scummvm-tools-1.7.0-binprefix.patch, scummvm-tools-1.7.0.ebuild:
+ fix install (bug #542560)
19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
scummvm-tools-1.7.0.ebuild:
diff --git a/games-engines/scummvm-tools/files/scummvm-tools-1.7.0-binprefix.patch b/games-engines/scummvm-tools/files/scummvm-tools-1.7.0-binprefix.patch
new file mode 100644
index 000000000000..604db075395c
--- /dev/null
+++ b/games-engines/scummvm-tools/files/scummvm-tools-1.7.0-binprefix.patch
@@ -0,0 +1,11 @@
+--- scummvm-tools-1.7.0.orig/Makefile.common
++++ scummvm-tools-1.7.0/Makefile.common
+@@ -312,7 +312,7 @@
+ install: $(TARGETS)
+ $(INSTALL) -p -m 0755 -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -p -m 0755 -d $(DESTDIR)$(DATADIR)/scummvm-tools
+- for i in $^ ; do $(INSTALL) -p -m 0755 $$i $(DESTDIR)$(BINDIR) ; done
++ for i in $^ ; do $(INSTALL) -p -m 0755 $$i $(DESTDIR)$(BINDIR)/$(EXEPREFIX)$$i ; done
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DATADIR)/scummvm-tools
+ $(INSTALL) -p -m 0644 $(srcdir)/gui/media/*.* $(DESTDIR)$(DATADIR)/scummvm-tools
+
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild
index d09f264148d0..595e33965230 100644
--- a/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild,v 1.6 2015/02/19 06:22:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.7.0.ebuild,v 1.7 2015/03/09 21:53:24 mr_bones_ Exp $
EAPI=5
WX_GTK_VER=2.8
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
src_prepare() {
rm -rf *.bat dists/win32
sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
+ epatch "${FILESDIR}/${P}-binprefix.patch"
}
src_configure() {
@@ -39,6 +40,7 @@ src_configure() {
--mandir=/usr/share/man \
--prefix="${GAMES_PREFIX}" \
--libdir="${GAMES_PREFIX}/lib" \
+ --datadir="${GAMES_DATADIR}" \
$(use_enable flac) \
$(use_enable iconv) \
$(use_enable iconv freetype) \
@@ -48,10 +50,7 @@ src_configure() {
}
src_install() {
- local f
- for f in $(find . -type f -perm +1 -print); do
- newgamesbin $f ${PN}-${f##*/} || die
- done
+ emake DESTDIR="${D}" EXEPREFIX="${PN}-" install
dodoc README TODO
prepgamesdirs
}