summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-04-12 06:08:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-04-12 06:08:45 +0000
commitee797f10a4cf4e769d217cf2c9fdfac186cde077 (patch)
tree4314fa8c3afb5daccaa4c5134c01bf3e8cefb6df /games-emulation
parentVersion bump. (diff)
downloadgentoo-2-ee797f10a4cf4e769d217cf2c9fdfac186cde077.tar.gz
gentoo-2-ee797f10a4cf4e769d217cf2c9fdfac186cde077.tar.bz2
gentoo-2-ee797f10a4cf4e769d217cf2c9fdfac186cde077.zip
old
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/atari800/atari800-1.3.6.ebuild96
-rw-r--r--games-emulation/atari800/atari800-2.0.1.ebuild96
-rw-r--r--games-emulation/atari800/files/digest-atari800-1.3.66
-rw-r--r--games-emulation/atari800/files/digest-atari800-2.0.16
4 files changed, 0 insertions, 204 deletions
diff --git a/games-emulation/atari800/atari800-1.3.6.ebuild b/games-emulation/atari800/atari800-1.3.6.ebuild
deleted file mode 100644
index ac80ab60403c..000000000000
--- a/games-emulation/atari800/atari800-1.3.6.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-1.3.6.ebuild,v 1.4 2006/12/01 21:18:53 wolf31o2 Exp $
-
-inherit games
-
-DESCRIPTION="Atari 800 emulator"
-HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
- mirror://sourceforge/atari800/xf25.zip"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ppc sparc x86"
-IUSE="sdl"
-
-RDEPEND="sdl? ( >=media-libs/libsdl-1.2.0 )
- !sdl? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- !sdl? (
- x11-libs/libXt
- x11-libs/libX11
- x11-proto/xextproto
- x11-proto/xproto )
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove some not-so-interesting ones
- rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
-}
-
-src_compile() {
- local target="x11"
- use sdl && target="sdl"
-
- cd src && \
- egamesconf \
- --enable-crashmenu \
- --enable-break \
- --enable-hints \
- --enable-asm \
- --enable-cursorblk \
- --enable-led \
- --enable-displayled \
- --enable-sndclip \
- --enable-linuxjoy \
- --enable-sound \
- --target=${target} \
- || die
- emake || die "emake failed"
-}
-
-src_install () {
- dogamesbin src/atari800 || die "dogamesbin failed"
- newman src/atari800.man atari800.6
- dodoc README.1ST DOC/*
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- insinto /etc
- doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use sdl ; then
- echo
- echo
- einfo 'The emulator has been compiled using the SDL libraries. By default,'
- einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- einfo 'screen is postage-stamp sized in the middle of your display.'
- echo
- einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- einfo 'add the entry "400x300" to the end of the list of modes:'
- echo
- einfo ' Section "Screen"'
- einfo ' [...]'
- einfo
- einfo ' Subsection "Display"'
- einfo ' Depth 16'
- einfo ' Modes "1600x1200" "1024x768" "400x300"'
- einfo ' ViewPort 0 0'
- einfo ' EndSubsection'
- einfo ' EndSection'
- echo
- einfo 'You should not need to specify a modeline for this mode,'
- einfo 'since in most cases it is a standard mode calculated by'
- einfo 'the X server.'
- echo
- echo
- echo
- fi
-}
diff --git a/games-emulation/atari800/atari800-2.0.1.ebuild b/games-emulation/atari800/atari800-2.0.1.ebuild
deleted file mode 100644
index 11dfc1f5c8fa..000000000000
--- a/games-emulation/atari800/atari800-2.0.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-2.0.1.ebuild,v 1.2 2006/12/01 21:18:53 wolf31o2 Exp $
-
-inherit games
-
-DESCRIPTION="Atari 800 emulator"
-HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
- mirror://sourceforge/atari800/xf25.zip"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="sdl"
-
-RDEPEND="sdl? ( >=media-libs/libsdl-1.2.0 )
- !sdl? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- !sdl? (
- x11-libs/libXt
- x11-libs/libX11
- x11-proto/xextproto
- x11-proto/xproto )
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove some not-so-interesting ones
- rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
-}
-
-src_compile() {
- local target="x11"
- use sdl && target="sdl"
-
- cd src && \
- egamesconf \
- --enable-crashmenu \
- --enable-break \
- --enable-hints \
- --enable-asm \
- --enable-cursorblk \
- --enable-led \
- --enable-displayled \
- --enable-sndclip \
- --enable-linuxjoy \
- --enable-sound \
- --target=${target} \
- || die
- emake || die "emake failed"
-}
-
-src_install () {
- dogamesbin src/atari800 || die "dogamesbin failed"
- newman src/atari800.man atari800.6
- dodoc README.1ST DOC/*
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- insinto /etc
- doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use sdl ; then
- echo
- echo
- einfo 'The emulator has been compiled using the SDL libraries. By default,'
- einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- einfo 'screen is postage-stamp sized in the middle of your display.'
- echo
- einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- einfo 'add the entry "400x300" to the end of the list of modes:'
- echo
- einfo ' Section "Screen"'
- einfo ' [...]'
- einfo
- einfo ' Subsection "Display"'
- einfo ' Depth 16'
- einfo ' Modes "1600x1200" "1024x768" "400x300"'
- einfo ' ViewPort 0 0'
- einfo ' EndSubsection'
- einfo ' EndSection'
- echo
- einfo 'You should not need to specify a modeline for this mode,'
- einfo 'since in most cases it is a standard mode calculated by'
- einfo 'the X server.'
- echo
- echo
- echo
- fi
-}
diff --git a/games-emulation/atari800/files/digest-atari800-1.3.6 b/games-emulation/atari800/files/digest-atari800-1.3.6
deleted file mode 100644
index 12dbac4b7822..000000000000
--- a/games-emulation/atari800/files/digest-atari800-1.3.6
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 98b58d26aabeedb124233787677c32c3 atari800-1.3.6.tar.gz 1012231
-RMD160 943b5ab6beae25228c85f728462c8e8f68ce5027 atari800-1.3.6.tar.gz 1012231
-SHA256 4236db413d23d8c3694aa3581b2ceb169752f517fa5627d7fe17386763f3ca98 atari800-1.3.6.tar.gz 1012231
-MD5 4dc3b6b4313e9596c4d474785a37b94d xf25.zip 188942
-RMD160 e3960898223dd4d1b9a9cc5cfb1251bd726ea5a7 xf25.zip 188942
-SHA256 98ae0ad10413dd6f35ed80f5662dba6d790def70c7829046e52012a03b574b8a xf25.zip 188942
diff --git a/games-emulation/atari800/files/digest-atari800-2.0.1 b/games-emulation/atari800/files/digest-atari800-2.0.1
deleted file mode 100644
index f398b04a2d37..000000000000
--- a/games-emulation/atari800/files/digest-atari800-2.0.1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 47ae5b2261ec85e6efa25b6ee784149b atari800-2.0.1.tar.gz 939745
-RMD160 42b5f94dfe396cb8d62b7e4fe83958c385e14b4e atari800-2.0.1.tar.gz 939745
-SHA256 6e272db5ab7dba56257e189062e4ee05eb5a8d7aa5254eeb92691cfc9a79ca9e atari800-2.0.1.tar.gz 939745
-MD5 4dc3b6b4313e9596c4d474785a37b94d xf25.zip 188942
-RMD160 e3960898223dd4d1b9a9cc5cfb1251bd726ea5a7 xf25.zip 188942
-SHA256 98ae0ad10413dd6f35ed80f5662dba6d790def70c7829046e52012a03b574b8a xf25.zip 188942