summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-08 06:36:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-08 06:36:46 +0000
commitcc12fc82b511166e9a884fc64a432f92b94878ed (patch)
treef856b33f0931f230c63815903400c88ce168a073 /games-emulation
parentFix a typo in udev flag activation, bug #284037. (diff)
downloadgentoo-2-cc12fc82b511166e9a884fc64a432f92b94878ed.tar.gz
gentoo-2-cc12fc82b511166e9a884fc64a432f92b94878ed.tar.bz2
gentoo-2-cc12fc82b511166e9a884fc64a432f92b94878ed.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/ChangeLog8
-rw-r--r--games-emulation/openmsx/openmsx-0.7.0.ebuild5
-rw-r--r--games-emulation/openmsx/openmsx-0.7.2.ebuild55
3 files changed, 64 insertions, 4 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index 20a191d93c29..dbff208bdaeb 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/openmsx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.28 2009/08/10 07:16:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.29 2009/09/08 06:36:46 mr_bones_ Exp $
+
+*openmsx-0.7.2 (08 Sep 2009)
+
+ 08 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> openmsx-0.7.0.ebuild,
+ +openmsx-0.7.2.ebuild:
+ version bump
10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> openmsx-0.7.0.ebuild:
Missing media-libs/sdl-ttf depend.
diff --git a/games-emulation/openmsx/openmsx-0.7.0.ebuild b/games-emulation/openmsx/openmsx-0.7.0.ebuild
index 241c3d85ef37..fdde52b63218 100644
--- a/games-emulation/openmsx/openmsx-0.7.0.ebuild
+++ b/games-emulation/openmsx/openmsx-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.7.0.ebuild,v 1.2 2009/08/10 07:16:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.7.0.ebuild,v 1.3 2009/09/08 06:36:46 mr_bones_ Exp $
EAPI=2
inherit toolchain-funcs games
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="jack"
-RDEPEND="dev-lang/tcl
+DEPEND="dev-lang/tcl
dev-libs/libxml2
media-libs/libpng
media-libs/libsdl
@@ -23,7 +23,6 @@ RDEPEND="dev-lang/tcl
media-libs/sdl-ttf
virtual/opengl
jack? ( media-sound/jack-audio-connection-kit )"
-DEPEND="${RDEPEND}"
src_prepare() {
sed -i '/LINK_FLAGS+=/s/-s//' build/main.mk || die "sed failed"
diff --git a/games-emulation/openmsx/openmsx-0.7.2.ebuild b/games-emulation/openmsx/openmsx-0.7.2.ebuild
new file mode 100644
index 000000000000..16bdb748b1f7
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-0.7.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.7.2.ebuild,v 1.1 2009/09/08 06:36:46 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="http://openmsx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="jack"
+
+DEPEND="dev-lang/tcl
+ dev-libs/libxml2
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/glew
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ virtual/opengl
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+src_prepare() {
+ sed -i \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ build/main.mk \
+ || die "sed failed"
+ sed -i \
+ -e "/DISABLED/s:$:$(use jack || echo JACK):" \
+ -e '/SYMLINK/s:true:false:' \
+ build/custom.mk \
+ || die "sed custom.mk failed"
+ find share/extensions -type f -exec chmod -x '{}' +
+}
+
+src_compile() {
+ emake \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ INSTALL_BINARY_DIR="${D}${GAMES_BINDIR}" \
+ INSTALL_SHARE_DIR="${D}${GAMES_DATADIR}"/${PN} \
+ INSTALL_DOC_DIR="${D}"/usr/share/doc/${PF} \
+ install || die "emake install failed"
+ dodoc ChangeLog README
+ prepgamesdirs
+}