summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 19:39:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 19:39:07 +0000
commit994aa67797571a0b4d49f2a8343dfd6f469b2fe7 (patch)
tree3b2cae5e3c91bbd12f17ec796515ba2989455ea1 /games-emulation
parentAdded modular X dependencies and closing bug #121522. (diff)
downloadgentoo-2-994aa67797571a0b4d49f2a8343dfd6f469b2fe7.tar.gz
gentoo-2-994aa67797571a0b4d49f2a8343dfd6f469b2fe7.tar.bz2
gentoo-2-994aa67797571a0b4d49f2a8343dfd6f469b2fe7.zip
Added modular X dependencies and closing bug #121527.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gnuboy/ChangeLog7
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3.ebuild20
2 files changed, 20 insertions, 7 deletions
diff --git a/games-emulation/gnuboy/ChangeLog b/games-emulation/gnuboy/ChangeLog
index 4b1760af6ce0..046bbaf856b0 100644
--- a/games-emulation/gnuboy/ChangeLog
+++ b/games-emulation/gnuboy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gnuboy
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/ChangeLog,v 1.8 2005/08/29 04:19:01 mr_bones_ Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/ChangeLog,v 1.9 2006/02/10 19:39:07 wolf31o2 Exp $
+
+ 10 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org> gnuboy-1.0.3.ebuild:
+ Added modular X dependencies and closing bug #121527.
29 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> gnuboy-1.0.3.ebuild:
more choices for gui - patch from James Rowe via bug #99983
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
index 6c8b7d14b4bc..064f66fbfb1f 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.10 2006/01/09 23:28:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.11 2006/02/10 19:39:07 wolf31o2 Exp $
inherit games
@@ -13,10 +13,20 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="X fbcon sdl svga"
-DEPEND="X? ( virtual/x11 )
- sdl? ( media-libs/libsdl )
+RDEPEND="sdl? ( media-libs/libsdl )
+ !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
+ X? (
+ || (
+ x11-libs/libXext
+ virtual/x11 ) )"
+DEPEND="${RDEPEND}
svga? ( media-libs/svgalib )
- !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )"
+ X? (
+ || (
+ (
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 ) )"
src_compile() {
local myconf