summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-12-04 05:30:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-12-04 05:30:37 +0000
commit98bee0272f4f4af66b525bf9fa4b389011599ad6 (patch)
tree7fcf705d7d535af90e9710fe5f51ab8e503711f9 /games-emulation
parentamd64 stable (diff)
downloadgentoo-2-98bee0272f4f4af66b525bf9fa4b389011599ad6.tar.gz
gentoo-2-98bee0272f4f4af66b525bf9fa4b389011599ad6.tar.bz2
gentoo-2-98bee0272f4f4af66b525bf9fa4b389011599ad6.zip
old
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/files/digest-zsnes-1.513
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-gzdirect.patch60
-rw-r--r--games-emulation/zsnes/zsnes-1.51.ebuild83
3 files changed, 0 insertions, 146 deletions
diff --git a/games-emulation/zsnes/files/digest-zsnes-1.51 b/games-emulation/zsnes/files/digest-zsnes-1.51
deleted file mode 100644
index 018d3f063974..000000000000
--- a/games-emulation/zsnes/files/digest-zsnes-1.51
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 328071775f88f7c3b9fdb94176e5e417 zsnes151src.tar.bz2 1071712
-RMD160 337407bf7e5516bcd7bf310c7b17d6d12a948750 zsnes151src.tar.bz2 1071712
-SHA256 eb013f824f5a9814a714cf0daaea3ea68a1c74fd741e5b0979fcb7964236a866 zsnes151src.tar.bz2 1071712
diff --git a/games-emulation/zsnes/files/zsnes-1.51-gzdirect.patch b/games-emulation/zsnes/files/zsnes-1.51-gzdirect.patch
deleted file mode 100644
index f076ffd7f5c1..000000000000
--- a/games-emulation/zsnes/files/zsnes-1.51-gzdirect.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Only in zsnes_1_50/src: aclocal.m4
-Only in zsnes_1_50/src: autom4te.cache
-Only in zsnes_1_50/src: config.h
-Only in zsnes_1_50/src: config.log
-Only in zsnes_1_50/src: config.status
-Only in zsnes_1_50.orig/src: configure
-diff -ur zsnes_1_50.orig/src/configure.in zsnes_1_50/src/configure.in
---- zsnes_1_50.orig/src/configure.in 2007-01-13 00:24:30.000000000 +0100
-+++ zsnes_1_50/src/configure.in 2007-01-13 00:27:50.000000000 +0100
-@@ -76,6 +76,7 @@
- AM_PATH_ZLIB(1.2.3,,[AC_MSG_ERROR(zlib >= 1.2.3 is required)])
- CFLAGS="$CFLAGS $ZLIB_CFLAGS"
- LDFLAGS="$LDFLAGS $ZLIB_LIBS"
-+AC_CHECK_FUNCS(gzdirect)
-
- dnl - libpng stuff
- AM_PATH_LIBPNG(1.2.0,,)
-diff -ur zsnes_1_50.orig/src/initc.c zsnes_1_50/src/initc.c
---- zsnes_1_50.orig/src/initc.c 2007-01-13 00:24:30.000000000 +0100
-+++ zsnes_1_50/src/initc.c 2007-01-13 00:38:25.000000000 +0100
-@@ -831,6 +831,35 @@
- }
- }
-
-+#ifndef HAVE_GZDIRECT
-+typedef struct gz_stream {
-+ z_stream stream;
-+ int z_err; /* error code for last stream operation */
-+ int z_eof; /* set if end of input file */
-+ FILE *file; /* .gz file */
-+ Byte *inbuf; /* input buffer */
-+ Byte *outbuf; /* output buffer */
-+ uLong crc; /* crc32 of uncompressed data */
-+ char *msg; /* error message */
-+ char *path; /* path name for debugging only */
-+ int transparent; /* 1 if input file is not a .gz file */
-+ char mode; /* 'w' or 'r' */
-+ z_off_t start; /* start of compressed data in file (header skipped) */
-+ z_off_t in; /* bytes into deflate or inflate */
-+ z_off_t out; /* bytes out of deflate or inflate */
-+ int back; /* one character push-back */
-+ int last; /* true if push-back is last character */
-+} gz_stream;
-+
-+int gzdirect (gzFile file)
-+{
-+ gz_stream *s = (gz_stream*)file;
-+
-+ if (s == NULL || s->mode != 'r') return 0;
-+ return s->transparent;
-+}
-+#endif
-+
- void loadGZipFile(char *filename)
- {
- //Open file for size reading
-Only in zsnes_1_50/src: Makefile
-Only in zsnes_1_50/src: makefile.dep
-Only in zsnes_1_50/src/tools: fileutil.o
-Only in zsnes_1_50/src/tools: strutil.o
diff --git a/games-emulation/zsnes/zsnes-1.51.ebuild b/games-emulation/zsnes/zsnes-1.51.ebuild
deleted file mode 100644
index 19aa7df43b1c..000000000000
--- a/games-emulation/zsnes/zsnes-1.51.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51.ebuild,v 1.12 2007/03/18 20:30:48 beandog Exp $
-
-inherit eutils autotools flag-o-matic toolchain-funcs games
-
-DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
-HOMEPAGE="http://www.zsnes.com/ http://ipherswipsite.com/zsnes/"
-SRC_URI="mirror://sourceforge/zsnes/${PN}${PV//./}src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="ao custom-cflags opengl png"
-
-RDEPEND="media-libs/libsdl
- >=sys-libs/zlib-1.2.3-r1
- amd64? ( app-emulation/emul-linux-x86-sdl )
- ao? ( media-libs/libao )
- opengl? ( virtual/opengl )
- png? ( media-libs/libpng )"
-DEPEND="${RDEPEND}
- dev-lang/nasm
- amd64? ( >=sys-apps/portage-2.1 )"
-
-S=${WORKDIR}/${PN}_${PV//./_}/src
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fixing compilation without libpng installed
- epatch "${FILESDIR}"/${P}-libpng.patch
-
- # Workaround for old libz
- [[ "${ARCH}" = amd64 ]] && epatch "${FILESDIR}"/${P}-gzdirect.patch
-
- # Remove hardcoded CFLAGS and LDFLAGS
- if use custom-cflags; then
- sed -i -e '/^\s*CFLAGS=.* -fomit-frame-pointer /d' \
- configure.in || die
- append-flags -fomit-frame-pointer -D__RELEASE__
- else
- strip-flags
- fi
- sed -i \
- -e 's:^\s*STRIP="-s":STRIP="":' \
- -e 's:^\s*CFLAGS=.* -I\/usr\/local\/include .*$:CFLAGS="${CFLAGS} -I.":' \
- -e '/^\s*LDFLAGS=.* -L\/usr\/local\/lib /d' \
- configure.in || die
-
- eautoreconf
-}
-
-src_compile() {
- tc-export CC
-
- use amd64 && multilib_toolchain_setup x86
-
- local myconf=""
- use custom-cflags && myconf="--disable-cpucheck force_arch=no"
-
- egamesconf \
- $(use_enable ao libao) \
- $(use_enable png libpng) \
- $(use_enable opengl) \
- --disable-debug \
- --enable-release \
- ${myconf} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin zsnes || die "dogamesbin failed"
- newman linux/zsnes.1 zsnes.6
- dodoc ../docs/{readme.1st,*.txt,README.LINUX}
- dodoc ../docs/readme.txt/*
- dohtml -r ../docs/readme.htm/*
- make_desktop_entry zsnes ZSNES zsnes.png
- newicon icons/48x48x32.png ${PN}.png
- prepgamesdirs
-}