summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-04 04:53:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-04 04:53:39 +0000
commit9186f6383cacda3227df3ac132450aca47131954 (patch)
tree4f4ade9d38f88b1e7363ad99a67559c25922d189 /games-emulation
parentVersion bump. (diff)
downloadgentoo-2-9186f6383cacda3227df3ac132450aca47131954.tar.gz
gentoo-2-9186f6383cacda3227df3ac132450aca47131954.tar.bz2
gentoo-2-9186f6383cacda3227df3ac132450aca47131954.zip
version bump (bug #397551)
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog9
-rw-r--r--games-emulation/stella/stella-3.5.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index e5eb6096b37c..fce2c92dae7e 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.64 2011/11/10 16:39:06 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.65 2012/01/04 04:53:39 mr_bones_ Exp $
+
+*stella-3.5 (04 Jan 2012)
+
+ 04 Jan 2012; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.5.ebuild:
+ version bump (bug #397551)
10 Nov 2011; Michael Sterrett <mr_bones_@gentoo.org> stella-3.4.ebuild:
build with newer zlib (bug #390093)
diff --git a/games-emulation/stella/stella-3.5.ebuild b/games-emulation/stella/stella-3.5.ebuild
new file mode 100644
index 000000000000..5aa3dbc1e041
--- /dev/null
+++ b/games-emulation/stella/stella-3.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.5.ebuild,v 1.1 2012/01/04 04:53:39 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,video]
+ x11-libs/libX11
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile || die
+ sed -i \
+ -e '/Icon/s/.png//' \
+ -e '/Categories/s/Application;//' \
+ src/unix/stella.desktop || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}