summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-05 07:42:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-05 07:42:25 +0000
commit347aa5576aa359fd6d6bb764f8d78b5a3513170b (patch)
treed347e6eace1fd1345c79add3712dcc69fca6961c /games-emulation
parentVersion bump thanks to Mario Fetka (geos_one, bug #339721). Remove empty DEPE... (diff)
downloadgentoo-2-347aa5576aa359fd6d6bb764f8d78b5a3513170b.tar.gz
gentoo-2-347aa5576aa359fd6d6bb764f8d78b5a3513170b.tar.bz2
gentoo-2-347aa5576aa359fd6d6bb764f8d78b5a3513170b.zip
Respect LDFLAGS. Bug #337184
(Portage version: 2.1.9.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/daphne/ChangeLog8
-rw-r--r--games-emulation/daphne/daphne-1.0.ebuild22
-rw-r--r--games-emulation/daphne/files/daphne-1.0-ldflags.patch22
3 files changed, 41 insertions, 11 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index dfdf556bb328..c2399ee3f781 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/daphne
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.15 2009/11/21 19:18:09 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.16 2010/10/05 07:42:25 tupone Exp $
+
+ 05 Oct 2010; Tupone Alfredo <tupone@gentoo.org> daphne-1.0.ebuild,
+ +files/daphne-1.0-ldflags.patch:
+ Respect LDFLAGS. Bug #337184 by flameeyes@gentoo.org
21 Nov 2009; Markus Meier <maekke@gentoo.org> daphne-1.0.ebuild:
x86 stable, bug #288963
diff --git a/games-emulation/daphne/daphne-1.0.ebuild b/games-emulation/daphne/daphne-1.0.ebuild
index da9e05494768..0788bcdd0d57 100644
--- a/games-emulation/daphne/daphne-1.0.ebuild
+++ b/games-emulation/daphne/daphne-1.0.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.4 2009/11/21 19:18:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.5 2010/10/05 07:42:25 tupone Exp $
+EAPI="2"
inherit eutils toolchain-funcs games
@@ -13,25 +14,24 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="media-libs/libogg
+RDEPEND="media-libs/libogg
media-libs/libvorbis
media-libs/libsdl
media-libs/sdl-mixer
media-libs/glew"
+DEPEND="${RDEPEND}"
S="${WORKDIR}"/v_1_0/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Fix no sound issue with >=media-libs/libvorbis-1.2.0
epatch "${FILESDIR}/${P}"-vorbisfilefix.patch
# amd64 does not like int pointers
epatch "${FILESDIR}/${P}"-typefix.patch
- epatch "${FILESDIR}/${P}"-gcc43.patch
+ epatch "${FILESDIR}/${P}"-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i "/m_appdir =/s:\.:${GAMES_DATADIR}/${PN}:" \
io/homedir.cpp \
@@ -54,6 +54,11 @@ src_unpack() {
|| die "sed failed"
}
+src_configure() {
+ cd vldp2
+ egamesconf --disable-accel-detect
+}
+
src_compile() {
local archflags
@@ -70,7 +75,6 @@ src_compile() {
DFLAGS="${CXXFLAGS} ${archflags}" \
|| die "src build failed"
cd vldp2
- egamesconf --disable-accel-detect || die
emake \
-f Makefile.linux \
CC=$(tc-getCC) \
diff --git a/games-emulation/daphne/files/daphne-1.0-ldflags.patch b/games-emulation/daphne/files/daphne-1.0-ldflags.patch
new file mode 100644
index 000000000000..a5096a5b3927
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-1.0-ldflags.patch
@@ -0,0 +1,22 @@
+--- Makefile.old 2010-10-05 08:48:46.000000000 +0200
++++ Makefile 2010-10-05 08:49:10.000000000 +0200
+@@ -43,7 +43,7 @@
+ .SUFFIXES: .cpp
+
+ all: ${LOCAL_OBJS} sub
+- ${CXX} ${DFLAGS} ${OBJS} -o ${EXE} ${LIBS}
++ ${CXX} $(LDFLAGS) ${DFLAGS} ${OBJS} -o ${EXE} ${LIBS}
+
+ sub:
+ cd ldp-out && $(MAKE)
+--- vldp2/Makefile.linux.old 2010-10-05 09:29:52.000000000 +0200
++++ vldp2/Makefile.linux 2010-10-05 09:30:13.000000000 +0200
+@@ -33,7 +33,7 @@
+ all: vldp2
+
+ vldp2: ${OBJS}
+- ${CC} -shared -o ${LIBNAME} ${OBJS} ${LIBS}
++ ${CC} $(LDFLAGS) -shared -o ${LIBNAME} ${OBJS} ${LIBS}
+ cp ${LIBNAME} ../../.
+
+ clean: