summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 01:28:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 01:28:54 +0000
commit28f884aedf0bbd6438602dd79027cd2557c92486 (patch)
tree536112e7a45dad2447b6223e7fd609a572e7e5ab /games-emulation
parentVersion bump for various bug fixes - mostly to GIO, e.g MIME sniffing does no... (diff)
downloadgentoo-2-28f884aedf0bbd6438602dd79027cd2557c92486.tar.gz
gentoo-2-28f884aedf0bbd6438602dd79027cd2557c92486.tar.bz2
gentoo-2-28f884aedf0bbd6438602dd79027cd2557c92486.zip
version bump (bug #254111)
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/ChangeLog9
-rw-r--r--games-emulation/hatari/hatari-1.1.0.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 30439fbb415e..d2ee0010dc22 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.21 2008/07/24 17:30:56 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.22 2009/01/13 01:28:54 mr_bones_ Exp $
+
+*hatari-1.1.0 (13 Jan 2009)
+
+ 13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> +hatari-1.1.0.ebuild:
+ version bump (bug #254111)
24 Jul 2008; Raúl Porcel <armin76@gentoo.org> hatari-1.0.1.ebuild:
x86 stable wrt #231877
diff --git a/games-emulation/hatari/hatari-1.1.0.ebuild b/games-emulation/hatari/hatari-1.1.0.ebuild
new file mode 100644
index 000000000000..d8c7aa99044a
--- /dev/null
+++ b/games-emulation/hatari/hatari-1.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.1.0.ebuild,v 1.1 2009/01/13 01:28:54 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.berlios.de/"
+SRC_URI="mirror://berlios/hatari/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ sys-libs/readline
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ games-emulation/emutos"
+
+src_compile() {
+ egamesconf || die
+ # broken deps in the makefiles - bug #164068
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src/uae-cpu all || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ elog "has been installed in $(games_get_libdir) with a .img extension (there"
+ elog "are several from which to choose)."
+ elog
+ elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ elog " http://www.atari.st/"
+ elog
+ elog "The first time you run hatari, you should configure it to find the"
+ elog "TOS you prefer to use. Be sure to save your settings."
+ echo
+}