summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-02 16:41:45 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-02 16:41:45 +0000
commitceb415d0384ee545f66a5c6346f6debd0e7d4ee6 (patch)
tree70b8d5b5195c98c33aba72d6f79da17f21f242c3 /games-emulation/zsnes
parentVersion bump and fix for kernel 2.6.28 (diff)
downloadgentoo-2-ceb415d0384ee545f66a5c6346f6debd0e7d4ee6.tar.gz
gentoo-2-ceb415d0384ee545f66a5c6346f6debd0e7d4ee6.tar.bz2
gentoo-2-ceb415d0384ee545f66a5c6346f6debd0e7d4ee6.zip
Fix a (possible) compilation problem wrt bug #170108
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/ChangeLog8
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-depbuild.patch24
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r2.ebuild6
3 files changed, 34 insertions, 4 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index c522cc046871..bbc23d1c1c1d 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/zsnes
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.38 2008/05/09 19:14:57 drizzt Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.39 2009/02/02 16:41:45 drizzt Exp $
+
+ 02 Feb 2009; <drizzt@gentoo.org> +files/zsnes-1.51-depbuild.patch,
+ zsnes-1.51-r2.ebuild:
+ Fix a (possible) compilation problem wrt bug #170108
*zsnes-1.51-r2 (09 May 2008)
diff --git a/games-emulation/zsnes/files/zsnes-1.51-depbuild.patch b/games-emulation/zsnes/files/zsnes-1.51-depbuild.patch
new file mode 100644
index 000000000000..737d0c0100fb
--- /dev/null
+++ b/games-emulation/zsnes/files/zsnes-1.51-depbuild.patch
@@ -0,0 +1,24 @@
+--- src/tools/depbuild.cpp.orig 2006-12-27 12:04:05.000000000 +0100
++++ src/tools/depbuild.cpp 2009-02-02 17:24:17.980006252 +0100
+@@ -130,7 +130,20 @@
+ void dependency_calculate_asm(const char *filename)
+ {
+ string command = nasm + " " + nflags + " -M " + filename;
+- system(command.c_str());
++ FILE *fp = popen(command.c_str(), "r");
++ if (fp)
++ {
++ char line[256];
++ while (fgets(line, sizeof(line), fp)) //Process all lines of output
++ {
++ cout << line;
++ }
++ pclose(fp);
++ }
++ else
++ {
++ cerr << "Failed on: " << filename << "\n";
++ }
+ }
+
+ void dependency_calculate_psr(const char *filename)
diff --git a/games-emulation/zsnes/zsnes-1.51-r2.ebuild b/games-emulation/zsnes/zsnes-1.51-r2.ebuild
index f251fd8a8a7a..55bdddbded41 100644
--- a/games-emulation/zsnes/zsnes-1.51-r2.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r2.ebuild,v 1.1 2008/05/09 19:14:57 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r2.ebuild,v 1.2 2009/02/02 16:41:45 drizzt Exp $
inherit eutils autotools flag-o-matic toolchain-funcs multilib games
@@ -36,6 +36,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-gcc43.patch
# Fix bug #214697
epatch "${FILESDIR}"/${P}-libao-thread.patch
+ # Fix bug #170108
+ epatch "${FILESDIR}"/${P}-depbuild.patch
# Remove hardcoded CFLAGS and LDFLAGS
sed -i \