summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2006-09-17 18:15:57 +0000
committerChristian Birchinger <joker@gentoo.org>2006-09-17 18:15:57 +0000
commitee7709039d7dd29d1a68c91c337589c6e37d327f (patch)
treedfacbd3dd04575e453b8a33d20c8ddeadea60439 /games-emulation/mupen64
parentAdded games-emulation/mupen64 to package.mask for the no-multilib profiles. (diff)
downloadgentoo-2-ee7709039d7dd29d1a68c91c337589c6e37d327f.tar.gz
gentoo-2-ee7709039d7dd29d1a68c91c337589c6e37d327f.tar.bz2
gentoo-2-ee7709039d7dd29d1a68c91c337589c6e37d327f.zip
New revision which uses the included plugins and supports building on amd64.
(Portage version: 2.1-r2)
Diffstat (limited to 'games-emulation/mupen64')
-rw-r--r--games-emulation/mupen64/ChangeLog8
-rw-r--r--games-emulation/mupen64/files/digest-mupen64-0.5-r13
-rw-r--r--games-emulation/mupen64/mupen64-0.5-r1.ebuild100
3 files changed, 110 insertions, 1 deletions
diff --git a/games-emulation/mupen64/ChangeLog b/games-emulation/mupen64/ChangeLog
index 3e95b09b946b..d9d68566f604 100644
--- a/games-emulation/mupen64/ChangeLog
+++ b/games-emulation/mupen64/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mupen64
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.20 2006/08/21 18:22:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.21 2006/09/17 18:15:57 joker Exp $
+
+*mupen64-0.5-r1 (17 Sep 2006)
+
+ 17 Sep 2006; Christian Birchinger <joker@gentoo.org>
+ +mupen64-0.5-r1.ebuild:
+ New revision which uses the included plugins and supports building on amd64
21 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org> mupen64-0.5.ebuild:
avoid pre-stripping files; fixup warning message (bug #137824) - patch from
diff --git a/games-emulation/mupen64/files/digest-mupen64-0.5-r1 b/games-emulation/mupen64/files/digest-mupen64-0.5-r1
new file mode 100644
index 000000000000..f5e4ac023a01
--- /dev/null
+++ b/games-emulation/mupen64/files/digest-mupen64-0.5-r1
@@ -0,0 +1,3 @@
+MD5 11f994bed40e00fad5b82333b553e421 mupen64_src-0.5.tar.bz2 1981046
+RMD160 da916bc77f2f06ed92630332545dc3ee5ae1ff51 mupen64_src-0.5.tar.bz2 1981046
+SHA256 1b8e4188ab7a94d8125b77aed8725ee348c24818622b881adfe16be510487dfd mupen64_src-0.5.tar.bz2 1981046
diff --git a/games-emulation/mupen64/mupen64-0.5-r1.ebuild b/games-emulation/mupen64/mupen64-0.5-r1.ebuild
new file mode 100644
index 000000000000..7500c2a61d6c
--- /dev/null
+++ b/games-emulation/mupen64/mupen64-0.5-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.5-r1.ebuild,v 1.1 2006/09/17 18:15:57 joker Exp $
+
+inherit eutils games flag-o-matic multilib
+
+DESCRIPTION="A Nintendo 64 (N64) emulator"
+HOMEPAGE="http://mupen64.emulation64.com/"
+SRC_URI="http://mupen64.emulation64.com/files/${PV}/mupen64_src-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="sys-libs/zlib
+ opengl? ( virtual/opengl )
+ >=x11-libs/gtk+-2
+ amd64? ( app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-sdl )
+ media-libs/libsdl
+ media-libs/sdl-sound"
+
+# Block the now included external plugins.
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !games-emulation/mupen64-blight-input
+ !games-emulation/mupen64-glN64
+ !games-emulation/mupen64-jttl_sound"
+
+
+S=${WORKDIR}/mupen64_src-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${PN}-gentoo.patch"
+
+ cd "${S}"
+
+ sed -i "s:#undef WITH_HOME:#define WITH_HOME \"/usr/games/\":" config.h \
+ || die "sed failed"
+
+ sed -i \
+ -e '/strip/d' \
+ -e "s:CFLAGS[[:space:]]*=\(.*\):CFLAGS=-fPIC ${CFLAGS}:" \
+ -e "s:CXXFLAGS[[:space:]]*=\(.*\):CXXFLAGS=-fPIC ${CXXFLAGS}:" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+
+ emake mupen64 || die "emake failed on $d"
+ emake mupen64_nogui || die "emake failed"
+ emake plugins/mupen64_input.so || die "emake failed"
+ emake plugins/mupen64_hle_rsp_azimer.so || die "emake failed"
+ emake plugins/dummyaudio.so || die "emake failed"
+ emake plugins/mupen64_audio.so || die "emake failed"
+ emake plugins/mupen64_soft_gfx.so || die "emake failed"
+
+ emake plugins/blight_input.so || die "emake failed"
+ emake plugins/jttl_audio.so || die "emake failed"
+
+ if use opengl; then
+ emake plugins/glN64.so || die "emake failed"
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_LIBDIR}/${PN}
+
+ exeinto "${GAMES_BINDIR}"
+ doexe mupen64 || die "doexe failed"
+ doexe mupen64_nogui || die "doexe failed"
+
+ insinto "${dir}"
+ doins mupen64.ini jttl_audio.conf || "doins failed"
+
+ dodir ${dir}/save
+
+ cp -r lang roms plugins "${D}/${dir}/" \
+ || die "cp failed"
+
+ rm "${D}/${dir}/plugins/empty"
+ dodoc *.txt
+ cp doc/readme.pdf "${D}/usr/share/doc/${PF}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "If you are upgrading from previous version of mupen64"
+ ewarn "backup your saved games then do a rm -rf on your"
+ ewarn ".mupen64 directory. After launching then new mupen copy"
+ ewarn "your saved games to the original place."
+ echo
+}