summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-06 05:46:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-06 05:46:11 +0000
commitf1609ee0800170bd6e1f08b39c024c934b337597 (patch)
tree536a01b1e1408b546d07df13e644cdb928e86c58 /games-emulation/mupen64-riceplugin
parentuse games_get_libdir (diff)
downloadgentoo-2-f1609ee0800170bd6e1f08b39c024c934b337597.tar.gz
gentoo-2-f1609ee0800170bd6e1f08b39c024c934b337597.tar.bz2
gentoo-2-f1609ee0800170bd6e1f08b39c024c934b337597.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation/mupen64-riceplugin')
-rw-r--r--games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
index d86d38245798..284fbdceeb42 100644
--- a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
+++ b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.10 2006/06/01 18:51:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.11 2007/04/06 05:46:11 nyhm Exp $
-inherit toolchain-funcs eutils libtool flag-o-matic games
+inherit toolchain-funcs eutils flag-o-matic games
DESCRIPTION="an graphics plugin for mupen64"
SRC_URI="http://mupen64.emulation64.com/files/0.4/riceplugin.tar.bz2"
@@ -18,17 +18,16 @@ RDEPEND="sys-libs/zlib
media-libs/libsdl
virtual/glu
virtual/opengl"
-
DEPEND="${RDEPEND}
dev-lang/nasm"
-S="${WORKDIR}/riceplugin"
+S=${WORKDIR}/riceplugin
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-makefile.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-makefile.patch \
"${FILESDIR}"/${PN}-gtk2.patch \
"${FILESDIR}"/${PN}-compile.patch \
"${FILESDIR}"/${PN}-gcc4.patch
@@ -40,9 +39,9 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_LIBDIR}"/mupen64/plugins
- doexe *.so
- insinto "${GAMES_LIBDIR}"/mupen64/plugins
- doins *.ini
+ exeinto "$(games_get_libdir)"/mupen64/plugins
+ doexe *.so || die "doexe failed"
+ insinto "$(games_get_libdir)"/mupen64/plugins
+ doins *.ini || die "doins failed"
prepgamesdirs
}