summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-10 01:29:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-10 01:29:52 +0000
commit0ef1db3dfd19e10711b5016d03b9854ce672d408 (patch)
treea2c70b5906f409f1f256011a2fe9dbda5cab3775 /games-emulation/infones/infones-0.97.ebuild
parentVersion Bump. Update Homepage thanks to Thomas Cort <tcort@cs.ubishops.ca>. C... (diff)
downloadgentoo-2-0ef1db3dfd19e10711b5016d03b9854ce672d408.tar.gz
gentoo-2-0ef1db3dfd19e10711b5016d03b9854ce672d408.tar.bz2
gentoo-2-0ef1db3dfd19e10711b5016d03b9854ce672d408.zip
Version bump #118355 by Tupone Alfredo.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-emulation/infones/infones-0.97.ebuild')
-rw-r--r--games-emulation/infones/infones-0.97.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/infones/infones-0.97.ebuild b/games-emulation/infones/infones-0.97.ebuild
new file mode 100644
index 000000000000..694a357526c3
--- /dev/null
+++ b/games-emulation/infones/infones-0.97.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/infones/infones-0.97.ebuild,v 1.1 2006/01/10 01:29:52 vapier Exp $
+
+inherit games
+
+MY_P="InfoNES${PV//.}J_Src"
+DESCRIPTION="A fast and portable NES emulator"
+HOMEPAGE="http://www.geocities.co.jp/SiliconValley/5604/infones/"
+SRC_URI="http://prdownloads.sourceforge.jp/infones/16325/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}/linux
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:-O6:${CFLAGS}:" \
+ -e "/^LDFILGS/s:=:=${LDFLAGS} :" \
+ Makefile \
+ || die "sed Makefile failed"
+}
+
+src_install() {
+ dogamesbin InfoNES || die "dogamesbin failed"
+ dohtml ../doc/readme.html
+ prepgamesdirs
+}