summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-10-14 16:22:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-10-14 16:22:27 +0000
commit25546b617339ebfcde8f37e1315ccfe8db2dd47f (patch)
tree1f3afd4cf9f935b9d0065929226be92d21801a4f /games-emulation/gens
parentAdd a revision using EAPI 2 to depend on libgpod with python bindings. (diff)
downloadgentoo-2-25546b617339ebfcde8f37e1315ccfe8db2dd47f.tar.gz
gentoo-2-25546b617339ebfcde8f37e1315ccfe8db2dd47f.tar.bz2
gentoo-2-25546b617339ebfcde8f37e1315ccfe8db2dd47f.zip
version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-emulation/gens')
-rw-r--r--games-emulation/gens/ChangeLog8
-rw-r--r--games-emulation/gens/files/gens-2.15.5-romsdir.patch13
-rw-r--r--games-emulation/gens/gens-2.15.5.ebuild33
3 files changed, 53 insertions, 1 deletions
diff --git a/games-emulation/gens/ChangeLog b/games-emulation/gens/ChangeLog
index 5c2893992bed..9ea77a1f81ac 100644
--- a/games-emulation/gens/ChangeLog
+++ b/games-emulation/gens/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/gens
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.17 2008/09/10 22:00:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.18 2008/10/14 16:22:27 mr_bones_ Exp $
+
+*gens-2.15.5 (14 Oct 2008)
+
+ 14 Oct 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gens-2.15.5-romsdir.patch, +gens-2.15.5.ebuild:
+ version bump
*gens-2.15.4 (10 Sep 2008)
diff --git a/games-emulation/gens/files/gens-2.15.5-romsdir.patch b/games-emulation/gens/files/gens-2.15.5-romsdir.patch
new file mode 100644
index 000000000000..606efe2dd6f9
--- /dev/null
+++ b/games-emulation/gens/files/gens-2.15.5-romsdir.patch
@@ -0,0 +1,13 @@
+diff -ruN gens-rc3.5-opengl/src/gens/util/rom.c gens-rc3.5-opengl-patched/src/gens/util/rom.c
+--- src/gens/util/file/rom.c 2005-01-10 22:24:01.000000000 +0100
++++ src/gens/util/file/rom.c 2006-10-29 14:58:14.000000000 +0100
+@@ -411,6 +411,9 @@
+ create_file_chooser_dialog ("Open Rom", GTK_FILE_CHOOSER_ACTION_OPEN);
+ // fileselection_set_dir (fd.filesel, Rom_Dir);
+ addRomsFilter (widget);
++
++ gtk_file_chooser_set_current_folder (GTK_FILE_CHOOSER (widget), Rom_Dir);
++
+ res = gtk_dialog_run (GTK_DIALOG (widget));
+ if (res == GTK_RESPONSE_OK)
+ {
diff --git a/games-emulation/gens/gens-2.15.5.ebuild b/games-emulation/gens/gens-2.15.5.ebuild
new file mode 100644
index 000000000000..89f5f916a5d3
--- /dev/null
+++ b/games-emulation/gens/gens-2.15.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.5.ebuild,v 1.1 2008/10/14 16:22:27 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A Sega Genesis/CD/32X emulator"
+HOMEPAGE="http://gens.consolemul.com/"
+SRC_URI="mirror://sourceforge/gens/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2
+ >=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-romsdir.patch
+ append-ldflags -Wl,-z,noexecstack
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS README
+ prepgamesdirs
+}