summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-05 07:36:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-05 07:36:48 +0000
commitad8b8e0a03e4d4177a973adde7a58e09c68f54bf (patch)
tree58770ec783947841b2e57aea691bda0698e1c410 /games-emulation/fceultra/fceultra-0.81-r1.ebuild
parentaddress issues laid out by John Ratliff in bug #51173; tidy (Manifest recommit) (diff)
downloadgentoo-2-ad8b8e0a03e4d4177a973adde7a58e09c68f54bf.tar.gz
gentoo-2-ad8b8e0a03e4d4177a973adde7a58e09c68f54bf.tar.bz2
gentoo-2-ad8b8e0a03e4d4177a973adde7a58e09c68f54bf.zip
clean out old ebuilds and files
Diffstat (limited to 'games-emulation/fceultra/fceultra-0.81-r1.ebuild')
-rw-r--r--games-emulation/fceultra/fceultra-0.81-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/games-emulation/fceultra/fceultra-0.81-r1.ebuild b/games-emulation/fceultra/fceultra-0.81-r1.ebuild
deleted file mode 100644
index eb55bdf28ce4..000000000000
--- a/games-emulation/fceultra/fceultra-0.81-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.81-r1.ebuild,v 1.3 2004/02/20 06:26:47 mr_bones_ Exp $
-
-inherit gcc
-
-MY_P=fceu
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A portable NES/Famicom Emulator"
-HOMEPAGE="http://fceultra.sourceforge.net/"
-SRC_URI="http://fceultra.sourceforge.net/dev/${MY_P}${PV//.}src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -ppc"
-
-DEPEND="svga? ( media-libs/svgalib )
- sdl? ( media-libs/libsdl )"
-
-pkg_setup() {
- if [ `gcc-major-version` == 3 ] && [ `gcc-minor-version` == 2 ] && [ ${ARCH} == "x86" ] ; then
- eerror "Do not use gcc 3.2.x to compile the source code"
- eerror "on 80x86/IA32 platforms. It has a code generation"
- eerror "bug in it that will cause FCE Ultra to not work."
- die "cant compile on x86 with gcc-3.2.x"
- fi
-
- use sdl && return 0
- use svga && return 0
-
- eerror "You must have 'sdl' or 'svga' in your USE variable"
- die "unable to build SVGA or SDL versions"
-}
-
-src_compile() {
- mv Makefile.base Makefile.orig
- sed -e "s:\${TFLAGS}:\${TFLAGS} ${CFLAGS}:" \
- Makefile.orig > Makefile.base
-
- if [ `use sdl` ] ; then
- make -f Makefile.unixsdl || die "sdl make failed"
- mv fceu fceu-sdl
- make -f Makefile.unixsdl clean
- fi
- if [ `use svga` ] ; then
- make -f Makefile.linuxvga || die "svga make failed"
- mv fceu fceu-svga
- fi
-}
-
-src_install() {
- use sdl && dobin fceu-sdl
- use svga && dobin fceu-svga
- dodoc Documentation/{*,rel/readme-linux.txt}
-}