summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-05 04:56:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-05 04:56:02 +0000
commitef2ff641be48fb0296f5835ca8195c6a271bf8b2 (patch)
tree42eb8e8b364c584ed6345999fb35a79b66034843 /games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
parentStable x86; ldap is annoying :( (diff)
downloadgentoo-2-ef2ff641be48fb0296f5835ca8195c6a271bf8b2.tar.gz
gentoo-2-ef2ff641be48fb0296f5835ca8195c6a271bf8b2.tar.bz2
gentoo-2-ef2ff641be48fb0296f5835ca8195c6a271bf8b2.zip
fix gcc4 compiling with patch from Stephen Bridges (bug #133203)
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
index a884bc85e766..d4c48f8288c9 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.11 2006/02/10 20:43:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.12 2006/10/05 04:56:02 mr_bones_ Exp $
-inherit eutils gnuconfig games
+inherit eutils games
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://www.pknet.com/~joe/dgen-sdl.html"
@@ -16,21 +16,20 @@ IUSE="X mmx opengl"
RDEPEND="media-libs/libsdl
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}
- X? (
- || (
- x11-misc/imake
- virtual/x11 ) )
+ X? ( x11-misc/imake )
dev-lang/nasm"
src_unpack() {
unpack ${A}
- cd "${S}/star"
- epatch "${FILESDIR}/${P}-gcc34.patch" # for bug #116113
+ cd "${S}"
+ # gcc34.patch for bug #116113
+ # gcc4.patch for bug #133203
+ epatch \
+ "${FILESDIR}/${P}-gcc34.patch" \
+ "${FILESDIR}/${P}-gcc4.patch"
}
src_compile() {
- gnuconfig_update
-
egamesconf \
$(use_with opengl) \
$(use_with X x) \
@@ -39,7 +38,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README sample.dgenrc
prepgamesdirs
}