summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-06 00:21:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-06 00:21:20 +0000
commit9f93d8c81a024eda7e1518569ef989016c9b11c3 (patch)
tree1a0c8bb6fae8e1efbf6953b079d17774bd07e717 /games-emulation/advancemame
parentFix PEAR collision bug with mod_php. (diff)
downloadgentoo-2-9f93d8c81a024eda7e1518569ef989016c9b11c3.tar.gz
gentoo-2-9f93d8c81a024eda7e1518569ef989016c9b11c3.tar.bz2
gentoo-2-9f93d8c81a024eda7e1518569ef989016c9b11c3.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.97.0.ebuild84
-rw-r--r--games-emulation/advancemame/files/0.97.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.97.01
5 files changed, 107 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 4991686fa606..d5aa93eea5cf 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.29 2005/05/24 04:59:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.30 2005/06/06 00:21:20 mr_bones_ Exp $
+
+*advancemame-0.97.0 (06 Jun 2005)
+
+ 06 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.97.0-pic.patch, +advancemame-0.97.0.ebuild:
+ version bump
*advancemame-0.96.0 (24 May 2005)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index c661b5c9223f..1d27c9e5fa27 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,10 +1,12 @@
MD5 72de01f650854f9aea89de39a56f06c4 advancemame-0.96.0.ebuild 1994
+MD5 72de01f650854f9aea89de39a56f06c4 advancemame-0.97.0.ebuild 1994
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 b2dff050faa7ce859ea2e2f4d7c39368 advancemame-0.94.0.ebuild 1994
MD5 48b0aac93c0c286ca90a9a6405bcdb8a advancemame-0.95.0.ebuild 1994
MD5 8486742a1b7817f2fd4e23d9aed2c02f ChangeLog 5573
MD5 0727e29d4a4d201dc55062d7e2c740e7 files/digest-advancemame-0.94.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.95.0-pic.patch 344
+MD5 8c88c68e2c593b19752d0462dd5b8d35 files/digest-advancemame-0.97.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.94.0-pic.patch 344
MD5 1b789ea9eb6e14eb14582618b754d5fc files/digest-advancemame-0.95.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.96.0-pic.patch 344
diff --git a/games-emulation/advancemame/advancemame-0.97.0.ebuild b/games-emulation/advancemame/advancemame-0.97.0.ebuild
new file mode 100644
index 000000000000..eb97fc7867ec
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.97.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.97.0.ebuild,v 1.1 2005/06/06 00:21:20 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.97.0-pic.patch b/games-emulation/advancemame/files/0.97.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.97.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.97.0 b/games-emulation/advancemame/files/digest-advancemame-0.97.0
new file mode 100644
index 000000000000..0538103641c3
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.97.0
@@ -0,0 +1 @@
+MD5 560116e740c9f4dbb66c1961a7e276c4 advancemame-0.97.0.tar.gz 15194792