summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-10-09 18:58:14 +0000
committerDon Seiler <rizzo@gentoo.org>2004-10-09 18:58:14 +0000
commit75e257e5bdde46df64a5ff421fc784c6baf3c3ab (patch)
treed2c082ba40a299569d6f169842d960216097457a /games-board
parentStable on x86, alpha and ppc. (Manifest recommit) (diff)
downloadgentoo-2-75e257e5bdde46df64a5ff421fc784c6baf3c3ab.tar.gz
gentoo-2-75e257e5bdde46df64a5ff421fc784c6baf3c3ab.tar.bz2
gentoo-2-75e257e5bdde46df64a5ff421fc784c6baf3c3ab.zip
Version bump
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest8
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.381
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.38.ebuild45
4 files changed, 57 insertions, 4 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index e250faa274fd..f99c5cfcdb4a 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.18 2004/10/01 21:20:10 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.19 2004/10/09 18:58:14 rizzo Exp $
+
+*gnocatan-0.8.1.38 (09 Oct 2004)
+
+ 09 Oct 2004; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.38.ebuild:
+ Version bump
*gnocatan-0.8.1.37 (01 Oct 2004)
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index b743578ee25d..8e24bbe1c196 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -1,8 +1,10 @@
MD5 38f04c9c422c6ed9222c1f8d143c7027 ChangeLog 3568
-MD5 9fcc05472041ee59db1779f166f5aa1d gnocatan-0.8.1.37.ebuild 1065
-MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
MD5 a56a7859d968f27bdc5eeadddd5868d2 gnocatan-0.8.1.34.ebuild 810
+MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
MD5 e6b59733bfbfab6b72e0d87d486261f8 gnocatan-0.8.1.36.ebuild 796
-MD5 010dc25ad3ed3f9e0ec6c21e5e0db450 files/digest-gnocatan-0.8.1.34 70
+MD5 9fcc05472041ee59db1779f166f5aa1d gnocatan-0.8.1.37.ebuild 1065
+MD5 9fcc05472041ee59db1779f166f5aa1d gnocatan-0.8.1.38.ebuild 1065
MD5 ec79cf5aad9383a08f198502cb1a61d5 files/digest-gnocatan-0.8.1.36 70
+MD5 010dc25ad3ed3f9e0ec6c21e5e0db450 files/digest-gnocatan-0.8.1.34 70
MD5 d8ee072ea1a133e6f7e2192ecbf1e956 files/digest-gnocatan-0.8.1.37 70
+MD5 e205ad988b7b6043929b526d45a97e13 files/digest-gnocatan-0.8.1.38 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.38 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.38
new file mode 100644
index 000000000000..458e5bf77306
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.38
@@ -0,0 +1 @@
+MD5 6103f6c9285ae20b0f8a9bc034b5af5d gnocatan-0.8.1.38.tar.gz 2047334
diff --git a/games-board/gnocatan/gnocatan-0.8.1.38.ebuild b/games-board/gnocatan/gnocatan-0.8.1.38.ebuild
new file mode 100644
index 000000000000..8ba7bd507e61
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.38.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.38.ebuild,v 1.1 2004/10/09 18:58:14 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls debug X"
+
+RDEPEND="dev-libs/glib
+ dev-util/pkgconfig
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}