summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-06 04:44:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-06 04:44:05 +0000
commit5966996999b4c50f953d89b68d717347005872b7 (patch)
tree61d3f366e889d63f5ecca9433478f1445d511e36 /games-board
parentInitial import. (diff)
downloadgentoo-2-5966996999b4c50f953d89b68d717347005872b7.tar.gz
gentoo-2-5966996999b4c50f953d89b68d717347005872b7.tar.bz2
gentoo-2-5966996999b4c50f953d89b68d717347005872b7.zip
tidy
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/mah-jong-1.6.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-board/mah-jong/mah-jong-1.6.3.ebuild b/games-board/mah-jong/mah-jong-1.6.3.ebuild
index 2f852a2d5561..a1c9af9516ed 100644
--- a/games-board/mah-jong/mah-jong-1.6.3.ebuild
+++ b/games-board/mah-jong/mah-jong-1.6.3.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.6.3.ebuild,v 1.4 2004/11/11 00:51:27 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.6.3.ebuild,v 1.5 2005/07/06 04:44:05 mr_bones_ Exp $
inherit games
MY_P="mj-${PV}-src"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A networked Mah Jong program, together with a computer player"
HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
SRC_URI="http://www.stevens-bradfield.com/MahJong/Source/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc"
+KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND="virtual/x11
=x11-libs/gtk+-1.2*"
DEPEND="${RDEPEND}
- dev-lang/perl
- >=sys-apps/sed-4"
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e '/^.TH/ s/1/6/' xmj.man \
- || die "sed xmj.man failed"
+ || die "sed xmj.man failed"
sed -i \
-e "/^DESTDIR =/ s:=.*:= ${D}:" \
-e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
@@ -35,7 +35,7 @@ src_unpack() {
-e "/^MANSUFFIX =/ s:1:6:" \
-e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
-e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
- || die "sed Makefile failed"
+ || die "sed Makefile failed"
}
src_install() {
@@ -44,7 +44,7 @@ src_install() {
cp -R fallbacktiles/ \
tiles-numbered/ \
tiles-small/ "${D}${GAMES_DATADIR}/${PN}" \
- || die "cp failed"
+ || die "cp failed"
dodoc CHANGES ChangeLog *.txt
prepgamesdirs
}