summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2014-09-15 16:38:11 +0000
committerSebastian Pipping <sping@gentoo.org>2014-09-15 16:38:11 +0000
commit4fadc77b18ffc413c2cd7f5efe771a77357a91ca (patch)
tree20cf512982600c3cb62b734e102e511b6b518caa /games-board/xboard
parentfurther corrections; delete redundant deps on sqlite and options of testrunne... (diff)
downloadgentoo-2-4fadc77b18ffc413c2cd7f5efe771a77357a91ca.tar.gz
gentoo-2-4fadc77b18ffc413c2cd7f5efe771a77357a91ca.tar.bz2
gentoo-2-4fadc77b18ffc413c2cd7f5efe771a77357a91ca.zip
games-board/xboard: 4.7.3 (bug #522332)
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'games-board/xboard')
-rw-r--r--games-board/xboard/ChangeLog7
-rw-r--r--games-board/xboard/xboard-4.7.3.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/games-board/xboard/ChangeLog b/games-board/xboard/ChangeLog
index 28930743ca89..3eee2e1c7857 100644
--- a/games-board/xboard/ChangeLog
+++ b/games-board/xboard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/xboard
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.62 2014/03/18 01:17:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.63 2014/09/15 16:38:11 sping Exp $
+
+*xboard-4.7.3 (15 Sep 2014)
+
+ 15 Sep 2014; Sebastian Pipping <sping@gentoo.org> +xboard-4.7.3.ebuild:
+ Bump to 4.7.3 (bug #522332)
18 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/xboard-4.6.2-gentoo.patch, -files/xboard-4.6.2-gettext.patch,
diff --git a/games-board/xboard/xboard-4.7.3.ebuild b/games-board/xboard/xboard-4.7.3.ebuild
new file mode 100644
index 000000000000..f6243842b80b
--- /dev/null
+++ b/games-board/xboard/xboard-4.7.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/xboard-4.7.3.ebuild,v 1.1 2014/09/15 16:38:11 sping Exp $
+
+EAPI=5
+inherit autotools eutils fdo-mime gnome2-utils games
+
+DESCRIPTION="GUI for gnuchess and for internet chess servers"
+HOMEPAGE="http://www.gnu.org/software/xboard/"
+SRC_URI="mirror://gnu/xboard/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="Xaw3d +default-font gtk nls zippy"
+RESTRICT="test" #124112
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ virtual/libintl
+ x11-libs/cairo[X]
+ x11-libs/libXpm
+ default-font? (
+ media-fonts/font-adobe-100dpi[nls?]
+ media-fonts/font-misc-misc[nls?]
+ )
+ !gtk? (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.7.2-paths.patch \
+ "${FILESDIR}"/${PN}-4.7.2-gettext.patch \
+ "${FILESDIR}"/${PN}-4.7.2-configure-switches.patch \
+ "${FILESDIR}"/${PN}-4.7.2-gnuchess-default.patch \
+ "${FILESDIR}"/${PN}-4.7.2-Xaw3d.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --datadir=/usr/share \
+ $(use_enable nls) \
+ $(use_enable zippy) \
+ --disable-update-mimedb \
+ $(use_with gtk) \
+ $(use_with Xaw3d) \
+ $(usex gtk "--without-Xaw" "$(use_with !Xaw3d Xaw)") \
+ --with-gamedatadir="${GAMES_DATADIR}"/${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS COPYRIGHT ChangeLog NEWS README TODO ics-parsing.txt
+ use zippy && dodoc zippy.README
+ dohtml FAQ.html
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ elog "No chess engines are emerged by default! If you want a chess engine"
+ elog "to play with, you can emerge gnuchess or crafty."
+ elog "Read xboard FAQ for information."
+ if ! use default-font ; then
+ ewarn "Read the xboard(6) man page for specifying the font for xboard to use."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}