summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-04 16:24:33 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-04 16:24:33 +0000
commitc777243bbb3f0e895f58472e8674d59e47977111 (patch)
tree463b2d7f08f9564ef0c33e34da2587777c521e4f /games-board/r-katro/r-katro-0.7.0.ebuild
parentcatalyst's cdr support for now is Linux-specific, mask it until it's ported. (diff)
downloadgentoo-2-c777243bbb3f0e895f58472e8674d59e47977111.tar.gz
gentoo-2-c777243bbb3f0e895f58472e8674d59e47977111.tar.bz2
gentoo-2-c777243bbb3f0e895f58472e8674d59e47977111.zip
Fix nls support
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'games-board/r-katro/r-katro-0.7.0.ebuild')
-rw-r--r--games-board/r-katro/r-katro-0.7.0.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/games-board/r-katro/r-katro-0.7.0.ebuild b/games-board/r-katro/r-katro-0.7.0.ebuild
index 0de6453b77ec..839a84957ead 100644
--- a/games-board/r-katro/r-katro-0.7.0.ebuild
+++ b/games-board/r-katro/r-katro-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/r-katro/r-katro-0.7.0.ebuild,v 1.7 2006/04/23 06:38:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/r-katro/r-katro-0.7.0.ebuild,v 1.8 2006/10/04 16:24:33 nyhm Exp $
inherit games
@@ -13,8 +13,19 @@ SLOT="0"
KEYWORDS="~ppc x86"
IUSE="nls"
-DEPEND="=x11-libs/qt-3*
- virtual/glut"
+RDEPEND="=x11-libs/qt-3*
+ virtual/glut
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' \
+ $(find . -name 'Makefile.in*') \
+ || die "sed failed"
+}
src_compile() {
egamesconf $(use_enable nls) || die
@@ -23,7 +34,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS README TODO
prepgamesdirs
}