summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-08 13:29:29 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-08 13:29:29 +0000
commit4e3cc4d6177a2eb4221545d28622a4e091c8b4a5 (patch)
tree64db1aab53faaaf5fcadfe46f16898098ce51db7 /games-board/qgo
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-4e3cc4d6177a2eb4221545d28622a4e091c8b4a5.tar.gz
gentoo-2-4e3cc4d6177a2eb4221545d28622a4e091c8b4a5.tar.bz2
gentoo-2-4e3cc4d6177a2eb4221545d28622a4e091c8b4a5.zip
small compile fix
Diffstat (limited to 'games-board/qgo')
-rw-r--r--games-board/qgo/files/0.2-gcc.patch24
-rw-r--r--games-board/qgo/qgo-0.2.ebuild12
2 files changed, 33 insertions, 3 deletions
diff --git a/games-board/qgo/files/0.2-gcc.patch b/games-board/qgo/files/0.2-gcc.patch
new file mode 100644
index 000000000000..0d113732b156
--- /dev/null
+++ b/games-board/qgo/files/0.2-gcc.patch
@@ -0,0 +1,24 @@
+--- qgo-0.2/qgo/src/wavfile.c.orig 2004-06-08 09:20:12.783379736 -0400
++++ qgo-0.2/qgo/src/wavfile.c 2004-06-08 09:20:25.304476240 -0400
+@@ -134,6 +134,10 @@
+ static char emsg[2048];
+
+
++static void
++_v_erf(const char *format,va_list ap) {
++ vsprintf(emsg,format,ap); /* Capture message into emsg[] */
++}
+
+ /*
+ * Error reporting function for this source module:
+@@ -150,10 +154,6 @@
+ }
+
+
+-static void
+-_v_erf(const char *format,va_list ap) {
+- vsprintf(emsg,format,ap); /* Capture message into emsg[] */
+-}
+
+
+
diff --git a/games-board/qgo/qgo-0.2.ebuild b/games-board/qgo/qgo-0.2.ebuild
index f81dc2c2ccd9..75e347ce7bca 100644
--- a/games-board/qgo/qgo-0.2.ebuild
+++ b/games-board/qgo/qgo-0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-0.2.ebuild,v 1.2 2004/06/04 09:10:03 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-0.2.ebuild,v 1.3 2004/06/08 13:29:29 vapier Exp $
-inherit kde-functions
+inherit kde-functions eutils
need-qt 3
DESCRIPTION="A c++/qt go client and sgf editor"
@@ -11,9 +11,15 @@ SRC_URI="mirror://sourceforge/qgo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc.patch
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc qgo/README ChangeLog TODO