summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-27 06:41:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-27 06:41:02 +0000
commit2f8df3eb6253cb3c3765d2c3c92976684166f353 (patch)
tree6b565519978371446d96b2a7e540250a1aa1bff1 /games-board/gnubg
parentAdding shoutcast-server-bin to package.mask per security bug #75482. (diff)
downloadgentoo-2-2f8df3eb6253cb3c3765d2c3c92976684166f353.tar.gz
gentoo-2-2f8df3eb6253cb3c3765d2c3c92976684166f353.tar.bz2
gentoo-2-2f8df3eb6253cb3c3765d2c3c92976684166f353.zip
Add support for USE=opengl to track glgtkext support #47039 by Nicolai Lissner / Thomas R. (TRauMa).
Diffstat (limited to 'games-board/gnubg')
-rw-r--r--games-board/gnubg/ChangeLog6
-rw-r--r--games-board/gnubg/gnubg-0.14.2.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/games-board/gnubg/ChangeLog b/games-board/gnubg/ChangeLog
index d3b6a89b6e55..b354e4dd6f12 100644
--- a/games-board/gnubg/ChangeLog
+++ b/games-board/gnubg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gnubg
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.14 2004/12/27 04:31:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.15 2004/12/27 06:41:02 vapier Exp $
+
+ 27 Dec 2004; Mike Frysinger <vapier@gentoo.org> gnubg-0.14.2.ebuild:
+ Add support for USE=opengl to track glgtkext support #47039 by Nicolai
+ Lissner / Thomas R. (TRauMa).
17 Dec 2004; David Holm <dholm@gentoo.org> gnubg-0.14.2.ebuild:
Added to ~ppc.
diff --git a/games-board/gnubg/gnubg-0.14.2.ebuild b/games-board/gnubg/gnubg-0.14.2.ebuild
index 18eaf0168024..0facda1010c2 100644
--- a/games-board/gnubg/gnubg-0.14.2.ebuild
+++ b/games-board/gnubg/gnubg-0.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.14.2.ebuild,v 1.8 2004/12/27 04:31:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.14.2.ebuild,v 1.9 2004/12/27 06:41:02 vapier Exp $
inherit gnuconfig flag-o-matic games
@@ -15,7 +15,7 @@ SRC_URI="ftp://alpha.gnu.org/gnu/gnubg/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-amd64 ~ppc ~sparc x86"
-IUSE="gtk gtk2 readline python guile X gdbm truetype nls png esd arts nas"
+IUSE="gtk gtk2 readline python guile X gdbm truetype nls png esd arts nas opengl"
# FIXME does this need to DEPEND on netpbm?
RDEPEND="guile? ( dev-util/guile )
@@ -30,6 +30,7 @@ RDEPEND="guile? ( dev-util/guile )
=x11-libs/gtk+-1.2*
=dev-libs/glib-1*
)
+ opengl? ( x11-libs/gtkglext )
)
readline? ( sys-libs/readline )
X? ( virtual/x11 )
@@ -70,8 +71,11 @@ src_compile() {
else
myconf="${myconf} --with-gtk --without-gtk2"
fi
+ if use opengl ; then
+ myconf="${myconf} --with-board3d"
+ fi
else
- myconf="${myconf} --disable-gtktest"
+ myconf="${myconf} --disable-gtktest --without-board3d"
fi
if use esd || use arts ; then
myconf="${myconf} --with-sound"
@@ -84,8 +88,6 @@ src_compile() {
# configure script doesn't handle this option correctly.
# `use_with guile` \
egamesconf \
- --disable-dependency-tracking \
- --with-board3d \
$(use_with python) \
$(use_enable esd) \
$(use_enable arts artsc) \