summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-05-03 01:03:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-05-03 01:03:18 +0000
commita97f2cd6bbe0e3c7bfe5ce868a1f36c0aad444a3 (patch)
tree94a6762ea2cae2828beded11594ade5ce2d7d75b /games-board/domination
parentVersion bump. (diff)
downloadgentoo-2-a97f2cd6bbe0e3c7bfe5ce868a1f36c0aad444a3.tar.gz
gentoo-2-a97f2cd6bbe0e3c7bfe5ce868a1f36c0aad444a3.tar.bz2
gentoo-2-a97f2cd6bbe0e3c7bfe5ce868a1f36c0aad444a3.zip
version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/ChangeLog8
-rw-r--r--games-board/domination/domination-1.1.1.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/games-board/domination/ChangeLog b/games-board/domination/ChangeLog
index 585bf549ccee..77ecc9f81c64 100644
--- a/games-board/domination/ChangeLog
+++ b/games-board/domination/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/domination
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.14 2013/01/30 22:42:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.15 2013/05/03 01:03:18 mr_bones_ Exp $
+
+*domination-1.1.1.4 (03 May 2013)
+
+ 03 May 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +domination-1.1.1.4.ebuild:
+ version bump
30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-domination-1.1.1.1.ebuild:
diff --git a/games-board/domination/domination-1.1.1.4.ebuild b/games-board/domination/domination-1.1.1.4.ebuild
new file mode 100644
index 000000000000..0c8be2e98dd9
--- /dev/null
+++ b/games-board/domination/domination-1.1.1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/domination-1.1.1.4.ebuild,v 1.1 2013/05/03 01:03:18 mr_bones_ Exp $
+
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mkdir -p "${D}${GAMES_PREFIX}"/bin
+ cp "${S}"/FlashGUI.sh "${D}${GAMES_PREFIX}"/bin/${PN} || die
+ sed -i \
+ -e "s|cd.*|cd \"${GAMES_DATADIR}\"/${PN}|" \
+ "${D}${GAMES_PREFIX}"/bin/${PN} \
+ || die
+ chmod +x "${D}${GAMES_PREFIX}"/bin/${PN} || die
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r "${S}"/* || die
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}